Don't have a Xilinx account yet?

  • Choose to receive important news and product information
  • Gain access to special content
  • Personalize your web experience on Xilinx.com

Create Account

Username

Password

Forgot your password?
XClose Panel
Xilinx Home
Reply
Visitor
chetferry
Posts: 10
Registered: ‎06-23-2009
0

ISE 11.2, Impact can't find USB II cable, SLED 11 Linux 64 bit

Impact does not find USB II cable using libusb.  It works fine for me with ISE 10.1.03.

 

-My OS is Suse Linux 64 bit Enterprise Desktop 11

-I have libusb and fxload packages installed (works fine with ISE 10.1.03)

-I have run the setup_pcusb script

-I have tried setting  XIL_IMPACT_USE_LIBUSB env var to 0, 1, and not defined.

-I have tried creating a soft link in my home directory named libusb.so in my home directory to 

/usr/lib/libusb-0.1.so.4.4.4 

-I have tried creating a soft link in my home directory named libusb.so in my home directory to 

/usr/lib64/libusb-0.1.so.4.4.4 

 

-The USB cable LED turns green when it is plugged into computer

-USB II cable and target are proven good because it works when I switch back to ISE 10.1.03

 

 

Any ideas or thoughts would be most appreciated.  I am a Linux newbie and not sure what else to try.

 

 

 

Visitor
chetferry
Posts: 10
Registered: ‎06-23-2009
0

Re: ISE 11.2, Impact can't find USB II cable, SLED 11 Linux 64 bit

It turns out that you do need a soft link but I was putting it in the wrong directory and pointing it to the wrong .so file.

 

Here is what I did that got it working for me:

 

cd to the /usr/lib64 directory

 

sudo ln -s libusb-0.1.so.4 libusb.so

 

Also I had to set the XIL_IMPACT_USE_LIBUSB env var to 1.  Even though the Xilinx install notes for 11.1 say you do not need to define it.

 

This is on a 64 bit OS so I am assuming if you are running a 32 bit OS that you may want to do the same thing in the /usr/lib directory instead?