Don't have a Xilinx account yet?

  • Choose to receive important news and product information
  • Gain access to special content
  • Personalize your web experience on Xilinx.com

Create Account

Username

Password

Forgot your password?
XClose Panel
Xilinx Home
Reply
Visitor
applop
Posts: 5
Registered: ‎02-12-2014
0
Accepted Solution

WARNING:iMPACT:923 - Can not find cable, check cable setup !

Hi there

- it seems like i'm not the only one with this problem, however after trying almost everything I give up and need some expert advice.

 

some of the links I have used:

Windrvr6 not detecting JTAG with Ubuntu 12.04 or Windows 7 | Zedboard

Chipscope issue - Failed to detect cable Xilinx platform cable usb [Archive] - NetFPGA Forum

Xilinx ISE Installation Instructions - HacDC Wiki

Ubuntu 12.4 ISE14.2/14.1 USB Jtag Driver Install Error | Zedboard

How to connect Kintex 7 KC705 via Digilent USB por... - Xilinx User Community Forums

AR# 20429 Platform Cable USB - Frequently Asked Questions (FAQs)

+ alot more

 

I'm running an 64bit Arch linux based system with the 14.6 version of ISE installed.

 

My board is a Digilent Nexys 4 - https://www.digilentinc.com/Products/Detail.cfm?NavPath=2,400,1184&Prod=NEXYS4 and it comes with an onboard USB-JTAG port for programming, using the FTDI chip FT2232C

 

The following drivers are installed:

adept-runtime v. 2.13.1-3

adept-utilities v. 2.1.1-6

fxload v. 2008_10_13-6

libusbx v. 1.0.17-1

libgusb v. 0.1.6-1

libusb-compat v. 0.1.5-1

 

I've also tried to add the "libCseDigilent.so" and "libCseDigilent.xml" to the xilinx search path but not sure that i did it correct.

 

The problem is that I get the following Error message and no matter what I do, I can't make impact connect to the cable:

 

 - WARNING:iMPACT - The cable selected is not avaliable, please select a different one.

 

I also get this:

 - WARNING:iMPACT:923 - Can not find cable, check cable setup !Enumerating cables. Please wait.
PROGRESS_START - Starting Operation.
Connecting to cable (Usb Port - USB21).
Checking cable driver.
 Using libusb.
 Kernel release = 3.12.9-2-ARCH.
PROGRESS_END - End Operation.
Elapsed time =      0 sec.

 

Under Cable setup menu I understand that I should choose the:

Digilent USB JTAG Cable - but also understand that there should be a list to select from under Port but I cant select anything.

 

when I write "lsusb" in the terminalit returns:

 

Bus 001 Device 002: ID 8087:0020 Intel Corp. Integrated Rate Matching Hub
Bus 002 Device 002: ID 8087:0020 Intel Corp. Integrated Rate Matching Hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 006: ID 0403:6010 Future Technology Devices International, Ltd FT2232C Dual USB-UART/FIFO IC

when I write "ls -l /dev/ttyUSB*" in the terminal it returns:

 

crw-rw---- 1 root uucp 188, 1 Feb 12 17:01 /dev/ttyUSB1

 

when I write "dmesg" after inserting the usb it returns:

 

[ 6465.328336] usb 2-1.1: Detected FT2232H
[ 6465.328343] usb 2-1.1: Number of endpoints 2
[ 6465.328348] usb 2-1.1: Endpoint 1 MaxPacketSize 512
[ 6465.328354] usb 2-1.1: Endpoint 2 MaxPacketSize 512
[ 6465.328359] usb 2-1.1: Setting MaxPacketSize 512
[ 6465.328686] usb 2-1.1: FTDI USB Serial Device converter now attached to ttyUSB1
[ 6465.335845] ftdi_sio ttyUSB0: FTDI USB Serial Device converter now disconnected from ttyUSB0
[ 6465.335875] ftdi_sio 2-1.1:1.0: device disconnected

 

and when i unplug it returns:

 

[ 6591.888335] usb 2-1.1: USB disconnect, device number 7
[ 6591.888642] ftdi_sio ttyUSB1: FTDI USB Serial Device converter now disconnected from ttyUSB1
[ 6591.888665] ftdi_sio 2-1.1:1.1: device disconnected

So I assume that It is recognized okay by the system. And suspect that it is the ISE software that need some aditional driver information

 

my xilinx install path is /opt/Xilinx/14.6/ISE_DS/

 

hope this information is of any help for you to help me and if you need aditional info just ask and I'll try to provide it - thanks in advance

 

//Applop

Moderator
smarell
Posts: 1,047
Registered: ‎07-23-2012
0

Re: WARNING:iMPACT:923 - Can not find cable, check cable setup !

This AR may help you- http://www.xilinx.com/support/answers/29310.htm
-----------------------------------------------------------------------------------------------
Please mark the post as "Accept as solution" if the information provided answers your query/resolves your issue.

Give Kudos to a post which you think is helpful.
Visitor
applop
Posts: 5
Registered: ‎02-12-2014
0

Re: WARNING:iMPACT:923 - Can not find cable, check cable setup !

I have allready done this but doing it again - mistakes could have ocoured

 

running the command: sudo chmod +x setup_pcusb | sudo  ./setup_pcusb
gives:

 

--File /etc/hotplug/usb/xusbdfwu.fw/xusbdfwu.hex exists.
--File /etc/hotplug/usb/xusbdfwu.fw/xusbdfwu.hex version = 1030
--File xusbdfwu.hex exists.
--File xusbdfwu.hex version = 1030
--File xusbdfwu.hex is already updated.
--File /etc/hotplug/usb/xusbdfwu.fw/xusb_xlp.hex exists.
--File /etc/hotplug/usb/xusbdfwu.fw/xusb_xlp.hex version = 1028
--File xusb_xlp.hex exists.
--File xusb_xlp.hex version = 1028
--File xusb_xlp.hex is already updated.
--File /etc/hotplug/usb/xusbdfwu.fw/xusb_emb.hex exists.
--File /etc/hotplug/usb/xusbdfwu.fw/xusb_emb.hex version = 1028
--File xusb_emb.hex exists.
--File xusb_emb.hex version = 1028
--File xusb_emb.hex is already updated.
--File /etc/hotplug/usb/xusbdfwu.fw/xusb_xpr.hex exists.
--File /etc/hotplug/usb/xusbdfwu.fw/xusb_xpr.hex version = 2004
--File xusb_xpr.hex exists.
--File xusb_xpr.hex version = 2004
--File xusb_xpr.hex is already updated.
--File /etc/hotplug/usb/xusbdfwu.fw/xusb_xup.hex exists.
--File /etc/hotplug/usb/xusbdfwu.fw/xusb_xup.hex version = 1030
--File xusb_xup.hex exists.
--File xusb_xup.hex version = 1030
--File xusb_xup.hex is already updated.
--File /etc/hotplug/usb/xusbdfwu.fw/xusb_xp2.hex exists.
--File /etc/hotplug/usb/xusbdfwu.fw/xusb_xp2.hex version = 2300
--File xusb_xp2.hex exists.
--File xusb_xp2.hex version = 2300
--File xusb_xp2.hex is already updated.
--File /etc/hotplug/usb/xusbdfwu.fw/xusb_xse.hex exists.
--File /etc/hotplug/usb/xusbdfwu.fw/xusb_xse.hex version = 2006
--File xusb_xse.hex exists.
--File xusb_xse.hex version = 2006
--File xusb_xse.hex is already updated.
--Product ID 0007 is already in the usermap.
--Product ID 0009 is already in the usermap.
--Product ID 000d is already in the usermap.
--Product ID 000f is already in the usermap.
--Product ID 0013 is already in the usermap.
--Product ID 0015 is already in the usermap.
--Product ID 0008 is already in the usermap.

and also In my previous post it showed that:

 

- WARNING:iMPACT:923 - Can not find cable, check cable setup !Enumerating cables. Please wait.
PROGRESS_START - Starting Operation.
Connecting to cable (Usb Port - USB21).
Checking cable driver.
 Using libusb.
 Kernel release = 3.12.9-2-ARCH.
PROGRESS_END - End Operation.
Elapsed time =      0 sec.

 

so I am already using the libusb library.

 

But here goes the reinstall of that lib.

 

download, extraction and "./configure" went well

 

I stalled at 7. with the lib thingy thing... searching how to do it I ended up on the Arch wiki site and found the ANSWER!!!

 

Xilinx ISE WebPACK

 

did the four commands as root and now it works...!