Don't have a Xilinx account yet?

  • Choose to receive important news and product information
  • Gain access to special content
  • Personalize your web experience on Xilinx.com

Create Account

Username

Password

Forgot your password?
XClose Panel
Xilinx Home
Reply
Regular Visitor
particle
Posts: 35
Registered: ‎01-03-2010
0

Re: Xilinx ISE installation problem on windows8 Release Preview

Revision:  The 32-bit project navigator works, but since you can't use the 32-bit version of Impact on a 64-bit computer (it won't find the cable driver) and the open file dialog causes the 64-bit programs to crash, it doesn't seem possible to actually program a device on a 64-bit W8 machine.

Regular Visitor
particle
Posts: 35
Registered: ‎01-03-2010

Re: Xilinx ISE installation problem on windows8 Release Preview

I've come up with a workaround that seems to do the trick under 64-bit Windows 8 and ISE 14.4.

 

1)  Install 14.4 like normal

2)  Use the 32-bit version of Project Navigator to do your editing and compiling

3)  Launch the 32-bit version of Impact (Xilinx\14.4\ISE_DS\ISE\bin\nt\impact.exe)

4)  Launch the 64-bit version of the Remote Cable Server (Xilinx\14.4\ISE_DS\ISE\bin\nt64\cse_server.exe)

5)  Configure Impact to connect to a remote cable server at localhost (explained below)

6)  Initialize your chain, assign a configuration, and program as normal from that point on

 

The problem we're facing under Windows 8 64-bit is with the open file dialog.  The platform cable driver itself works fine.  Since you can't open a configuration file in 64-bit Impact without it crashing, it's necessary to use the 32-bit version.  The 32-bit version does not have this open file dialog glitch.  Since the 32-bit version can't interface with the 64-bit platform cable, it's necessary to use the remote cable server instead.  This steps around the issue.

 

If you haven't used the remote cable server before, here is what you need to do:   You can launch the cable server by running cse_server.exe in your nt64 folder (Xilinx\14.4\ISE_DS\ISE\bin\nt64\cse_server.exe).  At that point, go ahead and plug in your platform cable and let any drivers install if you're using a USB platform cable.  I don't think the parallel version will show anything on screen.  At that point, run the 32-bit version of Impact.  On a 64-bit computer no shortcut will have been made, but you can simply run it from your nt folder (Xilinx\14.4\ISE_DS\ISE\bin\nt\Impact.exe).  Double click on boundary scan like normal.  At that point you will have new menu options under the Output menu; select "Cable setup".  Select the type of cable you're using in the Communication Mode section and then select the "Remote" cable location below.  Type localhost into the "Host Name" box and click OK.  At this point, you should be able to use Impact like normal.

Newbie
adamz
Posts: 4
Registered: ‎02-06-2013
0

Re: Xilinx ISE installation problem on windows8 Release Preview

thx, the 32bit version works fine!

Newbie
amaxste
Posts: 2
Registered: ‎04-01-2013
0

Re: Xilinx ISE installation problem on windows8 Release Preview

I'm pretty sure that, for now, Xilinx in Windows 8 is not a complete solution.

 

My problem is with the ISE and EDK. ISE is automatically closed when I try to open a project or something, the EDK (Platform Studio) too.

 

xps.gui erros.

open project errors.

explore XPS tutorials errors.

 

in EDK, doesn`t create bitstream, doesn't export to SDK... etc etc etc.

 

So, I hope that Xilinx team will release a solution for Windows 8 soon.

 

;)

Regular Visitor
rvincentzio
Posts: 17
Registered: ‎03-14-2013
0

Re: Xilinx ISE installation problem on windows8 Release Preview

agreed, hope somebody at Xilinx reads this

Newbie
jmedma
Posts: 8
Registered: ‎04-06-2013
0

Re: Xilinx ISE installation problem on windows8 Release Preview

It is needed a Windows 8 version of Xilinx software (there has been more than time enough to adapt it), definetly!!!

 

Xilinx...just do it (copyright: adidas).

Newbie
dkrao410
Posts: 1
Registered: ‎05-12-2013
0

Re: Xilinx ISE installation problem on windows8

I had tried installing versions of Xilinx ISE 13.2  on my windows8 operating system .During installation 

 

 error shown: _Xsetup.exe has stopped working.

                         windows will find it out soon

 

I have consulted Microsoft reg the same, they suggested to contact Xilinx.

Please tell me the solution.

 

 

Regular Visitor
nachum
Posts: 17
Registered: ‎07-05-2009
0

Re: Xilinx ISE installation problem on windows8

For everyone trying to use Xilinx ISE 14.5 in Windows 8 x64. Rename libPortability.dll to libPortability.dll.orig, and copy libPortabilityNOSH.dll to libPortability.dll.

 

Do this in:

C:\Xilinx\14.5\ISE_DS\ISE\lib\nt64

C:\Xilinx\14.5\ISE_DS\common\lib\nt64 (copy dll from first location)

 

This turns off SmartHeap.

 

This will fix ISE and iMPACT crashes on file dialogs.

 

Nachum

 

This information was found from another thread, thank you howardp from Xilinx in this thread:

http://forums.xilinx.com/xlnx/board/crawl_message?board.id=DEENBD&message.id=1732

Newbie
mleone
Posts: 1
Registered: ‎06-17-2013
0

Re: Xilinx ISE installation problem on windows8

nachum,

Thanks for this. I can confirm this worked with my machine a Lenovo Y400 Windows 8 and ISE 14.5.

Newbie
pstelian2011
Posts: 1
Registered: ‎07-02-2013
0

Re: Xilinx ISE installation problem on windows8

Thank you nachum; Vivado is still not working. I have now Vivado 2013.2 x32 working, but x64 still crashing. Do you know a solution for that?

I did: D:\Xilinx\Vivado\2013.2\bin\unwrapped\win64.o\vvgl.exe D:\Xilinx\Vivado\2013.2\.\bin\vivado.bat -m32 (just add -m32)

than click on tha icon and set Compatibility to Windows 7 and checked "Run this program as an administrator"

This is needed because xil software guys build a protection; when I run start_gui I get:

ERROR: [Common 17-612] start_gui is not supported on Windows8.

Quite unusual from xil, in place of fixing the problem they forbid you to start the app in win8!? :(

stelian