UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

取消
显示结果 
搜索替代 
您的意思是: 
Highlighted
Visitor mk676910825
Visitor

关于ip核AXI UART Lite,写入无响应的问题

最近在调试ip核AXI UART Lite v2.0,使用的A7器件,在Axi接口写CTRL_REG(地址0xC),写发送fifo(地址0x4)都收不到s_axi_awready&s_axi_wready响应。 写入数据时s_axi_awvalid,s_axi_wvalid,同时置位1, s_axi_bready也置位1,  请问还有什么没有注意到的地方 ,另外能读到STAT_REG(地址0x8)值为0x04.

0 项奖励
4 条回复
Moderator
Moderator

回复: 关于ip核AXI UART Lite,写入无响应的问题

Hi, @mk676910825

 

可以贴出相关的波形图或者代码吗?

-------------------------------------------------------------------------------------------------
Don’t forget to reply, kudo, and accept as solution.
-------------------------------------------------------------------------------------------------
如果提供的信息能解决您的问题,请标记为“接受为解决方案”。
如果您认为帖子有帮助,请点击“奖励”。谢谢!
-------------------------------------------------------------------------------------------------
0 项奖励
Visitor mk676910825
Visitor

回复: 关于ip核AXI UART Lite,写入无响应的问题

附件中贴了两张波形图,word文件中有我发送的状态机,麻烦看一看,感谢

0 项奖励
Moderator
Moderator

回复: 关于ip核AXI UART Lite,写入无响应的问题

Hi, @mk676910825

 

你的复位信号是怎么施加的?建议将IP的复位信号施加时间长一些(一般需要大于等于16个clock cycles)。

-------------------------------------------------------------------------------------------------
Don’t forget to reply, kudo, and accept as solution.
-------------------------------------------------------------------------------------------------
如果提供的信息能解决您的问题,请标记为“接受为解决方案”。
如果您认为帖子有帮助,请点击“奖励”。谢谢!
-------------------------------------------------------------------------------------------------
0 项奖励
Visitor mk676910825
Visitor

回复: 关于ip核AXI UART Lite,写入无响应的问题

现在的复位信号是直接外接的上电复位

0 项奖励