取消
显示结果 
搜索替代 
您的意思是: 
Highlighted
358 次查看
注册日期: ‎12-24-2018

7z030的HP端子输出的IO无法拉低到0V

7Z030的两个HP端子采用1.8V的电源,N1和P5分别作为I2C的SCL和SDA使用,用了一段时间之后N1端子上出不来波形了,是一个恒高的1.8V电平;断开所有的负载,PL推挽输出一个方波,P5上测到的波形是正常的,N1上测到的波形低电平拉不到0V,低电平是1.27V左右,高电平是1.8V。感觉像是PIN坏了,这种问题如何处理,如何避免,多谢!

附件中102是SCL的波形,103是SDA的波形。

 

102.png
103.png
0 项奖励
5 条回复5
Highlighted
Xilinx Employee
Xilinx Employee
345 次查看
注册日期: ‎08-26-2010

回复: 7z030的HP端子输出的IO无法拉低到0V

Hi pangsifeng@126.com

需要确认一下这个上拉是否来自板上,将I/O本身置于高阻,看是否为高电平?如果为高,需要多大的下拉电阻能下拉到GND?

Thanks
Simon
-------------------------------------------------------------------------
Don't forget to reply, kudo, and accept as solution.
-------------------------------------------------------------------------
0 项奖励
Highlighted
339 次查看
注册日期: ‎12-24-2018

回复: 7z030的HP端子输出的IO无法拉低到0V

板上已经没有上拉了,7Z030的引脚处焊接了0欧电阻,现在把0欧电阻断开,已经与板上的所有负载或上下拉断开。
0 项奖励
Highlighted
Xilinx Employee
Xilinx Employee
332 次查看
注册日期: ‎08-08-2007

回复: 7z030的HP端子输出的IO无法拉低到0V

hi pangsifeng@126.com 

 

SCL直接输出一个低电平,电压是多少?

 

谢谢

Boris

------------------------------------------------------------------------------
Don't forget to reply, give kudo and accept as solution
------------------------------------------------------------------------------
0 项奖励
Highlighted
321 次查看
注册日期: ‎12-24-2018

回复: 7z030的HP端子输出的IO无法拉低到0V

没有说输出一个低电平;
是SCL没有方波了,输出一个1.8V的高电平;断开SCL的负载,从此引脚输出一个方波,推挽输出的,测得高电平是1.8V,低电平是1.27V,低电平不够低。
0 项奖励
Highlighted
Xilinx Employee
Xilinx Employee
288 次查看
注册日期: ‎08-08-2007

回复: 7z030的HP端子输出的IO无法拉低到0V

hi pangsifeng@126.com 

 

如果修改一下代码SCL只输出低电平,那么测出来也是1.2V的吗?

 

谢谢

Boris

------------------------------------------------------------------------------
Don't forget to reply, give kudo and accept as solution
------------------------------------------------------------------------------
0 项奖励