取消
显示结果 
显示  仅  | 搜索替代 
您的意思是: 
zhuangzhuang
Contributor
Contributor
2,789 次查看
注册日期: ‎11-18-2018

HDMI FrameBuffer实例设计报错

跳至解决方案

我参考HDMI FrameBuffer Example Design 2018.1,运行到$git checkout xlnx_rebase_v4.14 时显示“fatal: Not a git repository (or any of the parent directories): .git”,我想请教一下这一步的目的是干什么,这种情况要怎么解决?我没有解决这个问题我继续按照实例继续进行,到petalinux-build时,又产生了如下错误:

捕获.PNG

ERROR: linux-xlnx-4.14-xilinx-v2018.2+git999-r0 do_populate_lic: QA Issue: linux-xlnx: The LIC_FILES_CHKSUM does not match for file://COPYING;md5=d7810fab7487fb0aad327b76f1be7cd7
linux-xlnx: The new md5 checksum is bbea815ee2795b2f4230826c0c6b8814
linux-xlnx: Here is the selected license text:
vvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvv
The Linux Kernel is provided under:

SPDX-License-Identifier: GPL-2.0 WITH Linux-syscall-note

Being under the terms of the GNU General Public License version 2 only,
according with:

LICENSES/preferred/GPL-2.0

With an explicit syscall exception, as stated at:

LICENSES/exceptions/Linux-syscall-note

In addition, other licenses may also apply. Please see:

Documentation/process/license-rules.rst

for more details.
^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
linux-xlnx: Check if the license information has changed in /home/wzp/petalinux_project/linux-xlnx/COPYING to verify that the LICENSE value "GPLv2" remains valid [license-checksum]
ERROR: linux-xlnx-4.14-xilinx-v2018.2+git999-r0 do_populate_lic: Fatal QA errors found, failing task.
ERROR: linux-xlnx-4.14-xilinx-v2018.2+git999-r0 do_populate_lic: Function failed: populate_lic_qa_checksum
ERROR: Logfile of failure stored in: /home/wzp/petalinux_project/hdmi_frame/build/tmp/work/zcu102_zynqmp-xilinx-linux/linux-xlnx/4.14-xilinx-v2018.2+git999-r0/temp/log.do_populate_lic.16679
ERROR: Task (/home/wzp/opt/pkg/petalinux/components/yocto/source/aarch64/layers/meta-xilinx/meta-xilinx-bsp/recipes-kernel/linux/linux-xlnx_2018.2.bb:do_populate_lic) failed with exit code '1'
NOTE: Tasks Summary: Attempted 12 tasks of which 2 didn't need to be rerun and 1 failed.

这个要怎么解决,谢谢。

 

 

0 项奖励
1 解答

已接受的解答
weiyil
Moderator
Moderator
2,756 次查看
注册日期: ‎05-23-2018

Hi, @zhuangzhuang 

建议您检查一下Vivado的版本、petalinux的版本、以及您下载的kernel版本等是否一致,之后您可以再看一下是否还会报错。

-------------------------------------------------------------------------------------------------
Don’t forget to reply, kudo, and accept as solution.
-------------------------------------------------------------------------------------------------
如果提供的信息能解决您的问题,请标记为“接受为解决方案”。
如果您认为帖子有帮助,请点击“奖励”。谢谢!
-------------------------------------------------------------------------------------------------

在原帖中查看解决方案

0 项奖励
8 回复数
weiyil
Moderator
Moderator
2,778 次查看
注册日期: ‎05-23-2018

Hi, @zhuangzhuang 

petalinux是用的2018.2版本吗?可以再用2018.1版本的试一下。

-------------------------------------------------------------------------------------------------
Don’t forget to reply, kudo, and accept as solution.
-------------------------------------------------------------------------------------------------
如果提供的信息能解决您的问题,请标记为“接受为解决方案”。
如果您认为帖子有帮助,请点击“奖励”。谢谢!
-------------------------------------------------------------------------------------------------
0 项奖励
zhuangzhuang
Contributor
Contributor
2,769 次查看
注册日期: ‎11-18-2018
2018.2版本的用不了吗?
0 项奖励
weiyil
Moderator
Moderator
2,765 次查看
注册日期: ‎05-23-2018

Hi, @zhuangzhuang 

参考设计是2018.1版本的,工具版本最好是匹配的。

-------------------------------------------------------------------------------------------------
Don’t forget to reply, kudo, and accept as solution.
-------------------------------------------------------------------------------------------------
如果提供的信息能解决您的问题,请标记为“接受为解决方案”。
如果您认为帖子有帮助,请点击“奖励”。谢谢!
-------------------------------------------------------------------------------------------------
0 项奖励
zhuangzhuang
Contributor
Contributor
2,758 次查看
注册日期: ‎11-18-2018
我硬件工程采用的是vivado2018.2版本,petalinux2018.1版本会兼容吗?
0 项奖励
weiyil
Moderator
Moderator
2,757 次查看
注册日期: ‎05-23-2018

Hi, @zhuangzhuang 

建议您检查一下Vivado的版本、petalinux的版本、以及您下载的kernel版本等是否一致,之后您可以再看一下是否还会报错。

-------------------------------------------------------------------------------------------------
Don’t forget to reply, kudo, and accept as solution.
-------------------------------------------------------------------------------------------------
如果提供的信息能解决您的问题,请标记为“接受为解决方案”。
如果您认为帖子有帮助,请点击“奖励”。谢谢!
-------------------------------------------------------------------------------------------------

在原帖中查看解决方案

0 项奖励
zhuangzhuang
Contributor
Contributor
2,544 次查看
注册日期: ‎11-18-2018
我已经完成petalinux刚才的建立,我在zcu102上面运行示例中的hdmi-passthough应用时,显示如下信息:
root@xilinx-zcu102-zu9-es2-rev1_0-2018:/media/card# ls
Makefile build.sh menu.h modetest video_cmd.c video_cmd.sh
README.md menu.c menu.o video_cmd video_cmd.o video_lib
root@xilinx-zcu102-zu9-es2-rev1_0-2018:/media/card# sh ./video_cmd.sh
/sys/devices/platform/amba_pl@0/80060000.i2c/i2c-0/0-0050
Enter Password ->Password not accepted.
Enter Password ->Password not accepted.
Enter Password ->Password not accepted.

Initializing the application with HDCP disabled.

ERROR(video_lib/drm_helper.c:691) : failed to create buffer3
./video_cmd.sh: line 34: 2367 Aborted ./video_cmd $RX_SS_PATH $TX_SS_PATH $I2C_HDCP_EEPROM_PATH $TX_HDMI_CONNC_PATH
root@xilinx-zcu102-zu9-es2-rev1_0-2018:/media/card#
我不知道问题出现在哪?同时我还想询问一下,我要怎么在开发板上调试我自己的应用程序?
0 项奖励
mohamadoussayran
Adventurer
Adventurer
2,448 次查看
注册日期: ‎06-05-2018

hello @weiyil ,

i am facing the same problem when using the master branch of xilinx github.

how did you solve the problem?

 thanks

0 项奖励
chaorenbuhuifei
Observer
Observer
1,802 次查看
注册日期: ‎04-15-2019
您好!我编译的时候碰到了和您一样的问题,能否指教一下,我的联系方式2273667502(QQ),非常感谢
0 项奖励