取消
显示结果 
显示  仅  | 搜索替代 
您的意思是: 
zhangjun
Newbie
Newbie
992 次查看
注册日期: ‎06-24-2020

XCZU19EG板卡,JTAG无法扫描到ARM_DAP

自己设计的XCZU19EG板卡,上电以后JTAG无法扫描到ARM_DAP,会变成一个dummy_dap,如下图所示,并且下载bit文件立马报错。电源电压没有问题,PS_POR_B 和PS_SRST_B都已经拉高。PS_REF_CLK 为50MHz时钟。PS_ERROR_OUT 被拉低。请问这种情况会是什么原因造成的,还需要测试那些地方?

微信图片_20200624095935.png
0 项奖励
8 回复数
zhendon
Community Manager
Community Manager
934 次查看
注册日期: ‎08-31-2011

Hi,

你的配置模式是QSPI么?是否能切换到JTAG试一下?

-------------------------------------------------------------------------------------------------
Don’t forget to reply, kudo, and accept as solution.
-------------------------------------------------------------------------------------------------
如果提供的信息能解决您的问题,请标记为“接受为解决方案”。
如果您认为帖子有帮助,请点击“奖励”。谢谢!
-------------------------------------------------------------------------------------------------
0 项奖励
zhangjun
Newbie
Newbie
923 次查看
注册日期: ‎06-24-2020

我试过jtag模式,没啥变化
0 项奖励
yzhang
Moderator
Moderator
865 次查看
注册日期: ‎05-11-2010

你再确认一下POR和SRST管脚是否取消复位了吧。

zhangjun
Newbie
Newbie
845 次查看
注册日期: ‎06-24-2020

这两个信号确定都是高。现在通过jtag读取REGISTER.JTAG_ERROR_STATUS,发现其中的REGISTER.JTAG_ERROR_STATUS.BIT104_CSU_BR_ERR_TYPE的值是0x4400,对应UG1085中的解释是Mismatch in the PPK hash calculated from Boot header and PPK hash in eFUSE 。但是我不清楚这个是怎么产生的。REGISTER.JTAG_ERROR_STATUS.BIT104_CSU_BR_ERR_TYPE的值是最开始是3B00,对应Reading failed from the selected boot device,我插上SD卡以后就变成了0x4400.

0 项奖励
Wangchen
Newbie
Newbie
675 次查看
注册日期: ‎08-25-2020

你好,我也遇到相同问题,想问一下,你的问题解决了吗?

0 项奖励
axmei
Contributor
Contributor
627 次查看
注册日期: ‎05-04-2018

芯片是不是拆机的呢?采购渠道是什么?
zhendon
Community Manager
Community Manager
620 次查看
注册日期: ‎08-31-2011

Hi

正常情况下有两种可能性在jtag链接时发现PS显示为dummy_dap.

1. POR 和SRST没有释放

2. 配置模式设置成了QSPI,但是QSPI是空的。

其他情况比如PCB问题,电源问题,或者芯片来源等需要自查。

-------------------------------------------------------------------------------------------------
Don’t forget to reply, kudo, and accept as solution.
-------------------------------------------------------------------------------------------------
如果提供的信息能解决您的问题,请标记为“接受为解决方案”。
如果您认为帖子有帮助,请点击“奖励”。谢谢!
-------------------------------------------------------------------------------------------------
0 项奖励
afei2003
Newbie
Newbie
35 次查看
注册日期: ‎04-13-2021

你好,去年我也遇到同样的现象,FPGA核能识别,ARM核识别不到,昨天晚上我们工程师排查到问题点了。

总结就是类似时钟不稳定的问题,晶振接地不可靠导致,然后我们加焊了下晶振,问题竟然完美解决了。

 

0 项奖励