UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Observer spiwoks
Observer
527 Views
Registered: ‎08-24-2016

Booting ZynqMP brings up only ONE CPU!

Jump to solution

Hi all,

 

I am trying to boot a ZynqMP using JTAG according to the Zynq UltraScale+ MPSoC
Software Developer Guide. It works and boots Linux but only brings up ONE CPU.

 

I am using a TE0803 from Trenz and I have contacted them, but since booting the same
files from an SD card, they told me that only Xilinx can help me with this.

 

Any idea? On what could be wrong? Is it some register setting?

 

Cheers,

                            Ralf.

0 Kudos
1 Solution

Accepted Solutions
Observer spiwoks
Observer
568 Views
Registered: ‎08-24-2016

Re: Booting ZynqMP brings up only ONE CPU!

Jump to solution

Hi Kranthi,

 

Thank you so much for your reply.

The kernel command-line parameter "maxcpus=4" did the trick. Now it brings up all four CPUs.

 

Cheers,

                         Ralf.

View solution in original post

0 Kudos
2 Replies
Moderator
Moderator
518 Views
Registered: ‎06-27-2017

Re: Booting ZynqMP brings up only ONE CPU!

Jump to solution

@spiwoks,

 

Can you try adding "maxcpus=4" in kernel boot arguments? which version of petalinux/Kernel you are using?

Can you check how many cores are defined in "cpus" device node in your device tree?

 

Regards
Kranthi
--------------------------
Don't forget to reply, kudo, and accept as solution.

Best Regards
Kranthi
--------------------------
Don't forget to reply, kudo, and accept as solution.
Observer spiwoks
Observer
569 Views
Registered: ‎08-24-2016

Re: Booting ZynqMP brings up only ONE CPU!

Jump to solution

Hi Kranthi,

 

Thank you so much for your reply.

The kernel command-line parameter "maxcpus=4" did the trick. Now it brings up all four CPUs.

 

Cheers,

                         Ralf.

View solution in original post

0 Kudos