UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Adventurer
Adventurer
339 Views
Registered: ‎12-25-2014

Configure FPGA and Boot Application from MicroBlaze QSPI Flash not working

I am using KC705 board. I want to store a bitstream and application image to QSPI flash and on boot up, copy the application image from QSPI flash to DDR3 memory and start the application. Luckily I found an answer record doing just that on the KC705 board. 

AR# 55026 14.4 SDK - Configure FPGA and Boot Application from MicroBlaze QSPI Flash

I downloaded the prebuilt project & generated the mcs using the method mentioned in the attached pdf. I did it in ISE 14.7 (I don't have ISE 14.4 with which the project was created). Also, I had to program the QSPI flash using Vivado 2018.2 because Impact 14.7 was not able to detect the digilent cable setup.  
 
Even though Vivado 2018.2 showed mcs programing successful, the fpga was not booting up on power cycle. INIT DONE led was never on. Upon forcing boot using Vivado Hardware Manager, the boot was successful. The M0 pin of SW13 on KC705 was set to 1. So what is the issue here
Tags (4)
0 Kudos
1 Reply
Xilinx Employee
Xilinx Employee
250 Views
Registered: ‎09-01-2014

Re: Configure FPGA and Boot Application from MicroBlaze QSPI Flash not working

Since INT Done was not on, it looks like FPGA was not booting from flash memory.
Did you set Mode Pins (M[2:0]) = 001 for master SPI configuration mode?
0 Kudos