cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
xuantran
Contributor
Contributor
303 Views
Registered: ‎04-11-2019

QSPI boot mode works only if attaching a JTAG

Jump to solution

I download a flash image by using tool  Program Flash of Vitis. However, the flash image only boots when I attach a JTAG to the board and connect it to Hardware Server. Otherwise, the flash image doesn't boot from the flash.

Boot modes in the FSBL file and on the circuit are QSPI mode.

I don't understand this behavior of the image. Any ideas?

I will be grateful for any help you can provide.

0 Kudos
1 Solution

Accepted Solutions
denist
Xilinx Employee
Xilinx Employee
218 Views
Registered: ‎10-11-2011

In this particular use-case the MPSoC/RFSoC device doesn't have a UART connection and the stdout for FSBL has been set as "coresight".

We noticed in this case the FSBL hangs at the printing of the "banner" unless the JTAG cable is attached.

Changing the stdout for the FSBL from "coresight" to "none" fixes the issue.

-------------------------------------------------------------------------
Don’t forget to reply, kudo, and accept as solution.
-------------------------------------------------------------------------

View solution in original post

2 Replies
denist
Xilinx Employee
Xilinx Employee
219 Views
Registered: ‎10-11-2011

In this particular use-case the MPSoC/RFSoC device doesn't have a UART connection and the stdout for FSBL has been set as "coresight".

We noticed in this case the FSBL hangs at the printing of the "banner" unless the JTAG cable is attached.

Changing the stdout for the FSBL from "coresight" to "none" fixes the issue.

-------------------------------------------------------------------------
Don’t forget to reply, kudo, and accept as solution.
-------------------------------------------------------------------------

View solution in original post

xuantran
Contributor
Contributor
161 Views
Registered: ‎04-11-2019

Thanks!

0 Kudos