cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Anonymous
Not applicable
618 Views

Reset does not work when JTAG connected

Hello, I have tested Hello World application when booted from SD card, it works but now I would to program ZYNQ using JTAG. In SDK I first program FPGA (Xilinx => Program FPGA) the FPGA Done light turn on then I load bit file and elf file in Run Configuration and connect STDIO to console and click Run, see attachment. The application works as I see the output on console but when I press reset on the board, it does not reset even the FPGA done light also gone.   

 

I also check this when I un check "connect STDIO to Console" and connect SDK Terminal with UART configuration but there is no output.  

Untitled02.png
Untitled03.png
Untitled04.png
0 Kudos
3 Replies
Highlighted
Moderator
Moderator
558 Views
Registered: ‎06-27-2017

Re: Reset does not work when JTAG connected

Hi

 

which version of Xilinx tool you are using?

Can you try using "disconnect" command from xsct and then try reset?

 

-----------------------------------------------------------------------

Kindly mark this post as accepted solution if it helps.

Best Regards
Kranthi
--------------------------
Don't forget to reply, kudo, and accept as solution.
0 Kudos
Highlighted
Anonymous
Not applicable
551 Views

Re: Reset does not work when JTAG connected

I tried with reset button after disconnect command but on console I get the following. 

 

xsct% disconnect
xsct% Info: tcfchan#1 closed
connect
xsct% attempting to launch hw_server

****** Xilinx hw_server v2017.3
**** Build date : Oct 4 2017-20:12:17
** Copyright 1986-2017 Xilinx, Inc. All Rights Reserved.

INFO: hw_server application started
INFO: Use Ctrl-C to exit hw_server application

 

****** Xilinx hw_server v2017.3

**** Build date : Oct 4 2017-20:12:17

** Copyright 1986-2017 Xilinx, Inc. All Rights Reserved.

 

INFO: hw_server application started

INFO: Use Ctrl-C to exit hw_server application

 


INFO: To connect to this hw_server instance use url: TCP:127.0.0.1:3121

 

error deleting "C:/Users/abcxyz/AppData/Local/Temp/tcfqtD2x6W7aD": permission denied
tcfchan#2
xsct%

0 Kudos
Highlighted
Anonymous
Not applicable
537 Views

Re: Reset does not work when JTAG connected

I get e message of "permission denied" when I press the reset button. Is there any other command to run in xsct% before pressing reset button ? 

0 Kudos