cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Adventurer
Adventurer
638 Views
Registered: ‎02-05-2019

ZCU-104: USB Boot Mode with `dfu-util`

I was trying to setup to do USB Boot Mode using `dfu-util`.  I was referencing the instructions given in:

    • (Specifically, at page 92, "Boot Sequence for USB Boot Mode")

 

However:

  1. I'm using a ZCU104 Reference board instead of the ZCU102 referred to in that section, and...
  2. I'm trying to perform some steps using the `bootgen` command line tool, instead of the UI as indicated in those instructions.  I can supply the BIF files I used, if necessary.

 

I tried to refer to the ZCU104 Evaluation Board User Guide here:
    https://www.xilinx.com/support/documentation/boards_and_kits/zcu104/ug1267-zcu104-eval-bd.pdf
But this makes no mention of the USB boot mode.  Table 2-4 on page 16 lists only SD Card, JTAG, and SPI boot modes, but not USB boot mode.

I was able to build an FSBL image into a BOOT.bin (after modifying it as directed in the tutorial).  I booted the board with the SW6 switches set for USB mode.  Using dfu-util, I could see the Target system:

  • Found DFU: [03fd:0050] ver=0100, devnum=74, cfg=1, intf=0, alt=0, name="Xilinx DFU Downloader", serial="2A49876D9CC1AA4"

 

Then I loaded the BOOT.bin I had created.  This seemed to load successfully:

  • Download
  • [=========================] 100%       230616 bytes
    Download done.

    state(2) = dfuIDLE, status(0) = No error condition is present


    Done!

 

On UART1, I saw:

  • Xilinx Zynq MP First Stage Boot Loader
    Release 2018.2   Feb 20 2019  -  11:20:49

 

However, when I tried to follow-up and load usb_boot.bin, it seems the Target system is not in the correct mode to accept the connection:

  • dfu-util: Invalid DFU suffix signature
    dfu-util: A valid DFU suffix will be required in a future dfu-util release!!!
    dfu-util: No DFU capable USB device available

 

I'm not sure, but I'm guessing that the FSBL I built somehow isn't entering the correct mode for further stages of USB booting?  Perhaps the indicated modifications in the document aren't correct in my particular case?  Can you please advise, or direct me to someone that can help us on this issue?  Thanks!

 

0 Kudos
1 Reply
Highlighted
Xilinx Employee
Xilinx Employee
563 Views
Registered: ‎10-11-2011

Re: ZCU-104: USB Boot Mode with `dfu-util`

Maybe enable the detailed debug prints in the FSBL so it prints more than just the banner to see if it enters the porper mode.

I can take a look at the .bif if you want (just to double check).

-------------------------------------------------------------------------
Don’t forget to reply, kudo, and accept as solution.
-------------------------------------------------------------------------
0 Kudos