cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
arslanmalik93
Observer
Observer
485 Views
Registered: ‎05-14-2018

ZYNQ PCAP BITSTREAM Loading Error

Hello,

I am using Zedboard and trying to download a bin file to PL using PS pcap. I put two bin files in SD card and then wrote a code on SDK that read one of the bin files (that is specifed on uart) from the SD card, buffer it on a fix location in DDR memory (0x02000000) and then tansfer that data to PL via PCAP  xdevcfg_interrupt_example.c driver example.

Here are the issues i am facing :-

When i load the first bin file it loads perfectly to PL.

then i try to load again a second bit file  the xdevcfg_interrupt_example.c driver example shows that the entire process is succesful but infact it is not. I know that because first bin files turns on a led and second bit file is turns that led off. 

(both bin file funcitonality is verified  through jtag and there is no issue in them.)

Now when i repeat the same process again and again there comes a time when it starts working perfectly that is when i load first bin files using pcap it turns on a led and when i select 2nd bin files it turns that led off.

I have read the following status registers also to pinpoint problem 

0xF8007014  ,//XDCFG_STATUS_OFFSET
0xF800700C, //XDCFG_INT_STS_OFFSET
0xF8007010,  //XDCFG_INT_STS_MASK_OFFSET
0xF8000014, //XDCFG_STATUS_OFFSET

but i am unable to understand the issue.

Also when i change the DDR memory location from 0x02000000 to  0x02000001  to indicate the last DMA command of an overall transfer then even the first bin files fails to load. Can you tell me what could be the issue?

0 Kudos
0 Replies