UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Observer encrypt1977
Observer
1,978 Views
Registered: ‎03-19-2018

u-boot build failed

Jump to solution

Dear Sir,

 

      When I tried building uboot, I got the errors as the belowing:

*** Your GCC is older than 6.0 and is not supported
arch/arm/config.mk:69: recipe for target 'checkgcc6' failed
make: *** [checkgcc6] Error 1

 

      I installed codesourcery for xilinx from  https://github.com/xupsh/CodeSourcery.git.

and the version is : gcc version 4.7.2 (Sourcery CodeBench Lite 2012.09-104) 

 

     My ubuntu installed gcc 6.4 as the belowing message:

gcc version 6.4.0 20180424 (Ubuntu 6.4.0-17ubuntu1~16.04)

     Should I unstall codesourcery or how to change to use gcc 6.4 to compile Uboot?

    Thanks.

0 Kudos
1 Solution

Accepted Solutions
Scholar watari
Scholar
2,272 Views
Registered: ‎06-16-2013

Re: u-boot build failed

Jump to solution

Hi @encrypt1977

 

I see.

I know this solution.

Your problem is prefix issue and path issue.

 

Your solution depends on version of petalinux.

So, if you are facing like this issue, I suggest to make sure directory name in <patalinux install dir>/linux-i386/(gcc compiler name).

 

Best regards,

 

View solution in original post

0 Kudos
3 Replies
Scholar watari
Scholar
1,976 Views
Registered: ‎06-16-2013

Re: u-boot build failed

Jump to solution

Hi @encrypt1977

 

It's path issue.

Would you change path setting to add the path to GCC6.4 ?

 

Best regards,

 

0 Kudos
Observer encrypt1977
Observer
1,944 Views
Registered: ‎03-19-2018

Re: u-boot build failed

Jump to solution

Hi Watari,

 

    Thanks for your reply. If I comment out the path to codesourcery in .bashrc, it will report command not found.

but if i  use : export CROSS_COMPILE=arm-linux-gnueabihf- , it will compile successfully.

0 Kudos
Scholar watari
Scholar
2,273 Views
Registered: ‎06-16-2013

Re: u-boot build failed

Jump to solution

Hi @encrypt1977

 

I see.

I know this solution.

Your problem is prefix issue and path issue.

 

Your solution depends on version of petalinux.

So, if you are facing like this issue, I suggest to make sure directory name in <patalinux install dir>/linux-i386/(gcc compiler name).

 

Best regards,

 

View solution in original post

0 Kudos