UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Observer rahma1920
Observer
458 Views
Registered: ‎01-06-2019

Division error using system generator

Jump to solution

Hi all,

When i devide two numbers using Devide block in system generator, i have this message herror:

"aclk m_axis_dout_tdata m_axis_dout_tvalid s_axis_dividend_tdata s_axis_dividend_tvalid s_axis_divisor_tdata

s_axis_divisor_tvalid"

Error occurred during "Rate and Type Propagation".

some one can explain me where the error?

Thank you.

0 Kudos
1 Solution

Accepted Solutions
Moderator
Moderator
381 Views
Registered: ‎08-16-2018

Re: Division error using system generator

Jump to solution

To consider the latency of the divider-ip, run the simulation for longer duration(e.g. set the 'simulation stop time as 100). In this way you can see the correct output on the display-port. 

See PG060 for more details. 

 

 


/ 7\7     Meher Krishna Patel, PhD
\ \        Senior Product Application Engineer, Xilinx
/ /        
\_\/\7   It is not so much that you are within the cosmos as that the cosmos is within you...

View solution in original post

Screenshot_1.png
0 Kudos
3 Replies
Moderator
Moderator
423 Views
Registered: ‎08-16-2018

Re: Division error using system generator

Jump to solution

It seems you did not specify the rate in the constant blocks. 

Please share the design to investigate the issue further. 


/ 7\7     Meher Krishna Patel, PhD
\ \        Senior Product Application Engineer, Xilinx
/ /        
\_\/\7   It is not so much that you are within the cosmos as that the cosmos is within you...
0 Kudos
Observer rahma1920
Observer
404 Views
Registered: ‎01-06-2019

Re: Division error using system generator

Jump to solution

Hi,

I tried this time with larger numbers, but the result is always 0

The information of the constant and divide block is shown in the following fig:

devide.PNG
devide1.PNG
devide2.PNG
0 Kudos
Moderator
Moderator
382 Views
Registered: ‎08-16-2018

Re: Division error using system generator

Jump to solution

To consider the latency of the divider-ip, run the simulation for longer duration(e.g. set the 'simulation stop time as 100). In this way you can see the correct output on the display-port. 

See PG060 for more details. 

 

 


/ 7\7     Meher Krishna Patel, PhD
\ \        Senior Product Application Engineer, Xilinx
/ /        
\_\/\7   It is not so much that you are within the cosmos as that the cosmos is within you...

View solution in original post

Screenshot_1.png
0 Kudos