cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
7,618 Views
Registered: ‎09-03-2009

FFT simulation: Problem

Jump to solution
I have created FFT core and now want to simulate it, I am trying it using the verilog text fixture. when I run Simulate Behavioral Model, ModelSim opens but does not simulate it, rather it gives error. Can any one help what the problem is??
0 Kudos
1 Solution

Accepted Solutions
ywu
Xilinx Employee
Xilinx Employee
8,104 Views
Registered: ‎11-28-2007

From Windows program menu, go to Xilinx ISE Design Suite 11->ISE->Accessories->Simulation Library Compilation Wizard, then follow the instructions from the wizard. It will generate a modelsim.ini file in the ISE installation directory (%XILINX%/ise). I usually copy it and overwrite the one in Modelsim installation directory.

 

Cheers,

Jim

 

Message Edited by jimwu on 09-08-2009 01:39 PM
Cheers,
Jim

View solution in original post

0 Kudos
5 Replies
7,616 Views
Registered: ‎09-03-2009

It gives the error "ERROR LOADING DESIGN" in ModelSim,

 

Instantiation of 'SRL16E' failed. The design unit was not found.

Instantiation of 'LUT4' failed. The design unit was not found.

Instantiation of 'MUXF5' failed. The design unit was not found.

Instantiation of 'FDRE' failed. The design unit was not found.

 

Any many similar instantiation errors, Please help to get it solved

 

Regards

Yasir

Tags (2)
0 Kudos
ywu
Xilinx Employee
Xilinx Employee
7,609 Views
Registered: ‎11-28-2007

Did you compile the ISE simulation libraries (you can use "Simulation Library Compilation Wizard")? If yes, can you check if your modelsim.ini file has correct mappings to the compiled libraries?

 

Cheers,

Jim

 

Cheers,
Jim
0 Kudos
7,603 Views
Registered: ‎09-03-2009

Thanks Jim,

 

Can you please also tell me how to compile ISE  simulation libraries and from where to open this "Simulation Library Compilation Wizard"?

 

Regards

Yasir

 

 

0 Kudos
ywu
Xilinx Employee
Xilinx Employee
8,105 Views
Registered: ‎11-28-2007

From Windows program menu, go to Xilinx ISE Design Suite 11->ISE->Accessories->Simulation Library Compilation Wizard, then follow the instructions from the wizard. It will generate a modelsim.ini file in the ISE installation directory (%XILINX%/ise). I usually copy it and overwrite the one in Modelsim installation directory.

 

Cheers,

Jim

 

Message Edited by jimwu on 09-08-2009 01:39 PM
Cheers,
Jim

View solution in original post

0 Kudos
7,577 Views
Registered: ‎09-03-2009

Thankyou very much Jim.

It is working fine now.

 

Regards

Yasir

0 Kudos