UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Visitor shohamisr
Visitor
202 Views
Registered: ‎08-01-2019

FFT using VS2015 does not compile and run

Hi,

I tried to compile and run FFT V9.1 using Visual Studio 2015.

At first, it sent an linking error saying it can't find the definition of the functions xilinx_ip_xfft_v9_1_bitacc_simulate, xilinx_ip_xfft_v9_1_bitacc_create_state and xilinx_ip_xfft_v9_1_bitacc_destroy_state. On the FFT9.1 tutorial - Fast Fourier Transform v9.1 LogiCORE IP Product Guide, on the installation part, it says to "ensure that the directory in which the files
libIp_xfft_v9_1_bitacc_cmodel.dll and libgmp.dll are located is either in your
%PATH% environment variable, or is the directory in which you runs your executable that
calls the FFT C model", although I couldnt fine those files anywhere. What I did find from other forum from a coulple of years ago, is the file libIp_xfft_v8_0_bitacc_cmodel.dll and libIp_xfft_v8_0_bitacc_cmodel.lib, and V7_1.

When I tried to change the functions on the fft code to use those libraries, it compiled, but when I try to run, it sends a system error (on the attached file). I tried to put manually the MSVCR90.dll file (downloaded from dll-flies.com) on System32 folder, and tried to reinstall VS but that wasn't helpful.

My questions are:

1. Where can I find the V9_1 libraries?

2. Is the V8_0 is good enough, or maybe that is the reason for the system error (the attached file)?

3. How can I resolve the system error? and what I need to do in order that it won't send me that error again?

4. Is there something I need to adjust when I try to run vivado files in VS?

If someone can help me I'll be very grateful.

Thanks,

Shoham 

fft error.JPG
0 Kudos