cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Highlighted
Visitor
Visitor
1,716 Views
Registered: ‎04-18-2018

How to use AXI-Stream in System Generator Design?

Hi,

 

I'm having a big problem with AXI Stream in SysGen Tool ( and also in Model Composer).

I've already read the tutorials and previous message in this forum, but I don't understand the workflow.

 

Is there anyone that can tell me simply HOW to configure an AXI Stream ? 
I understand I have to put three signals named using the same prefix, but when I export this in Vivado, It doesn't work and port is not an AXI Stream.

 

 

Thank you so much

0 Kudos
7 Replies
Highlighted
Scholar
Scholar
1,685 Views
Registered: ‎06-20-2017

Which tutorials did you read?

0 Kudos
Highlighted
Xilinx Employee
Xilinx Employee
1,650 Views
Registered: ‎08-02-2007

@enprevo

 

In the Gateway In, please ensure you set interface type to AXI4-Stream, the interface type isn't AXI4-Stream in the screenshot, but it shows you where to set the correct type.I can't remember since which version sysgen starts to support AXI- Stream. If you don't see this option, please upgrade your Sysgen version to the latest v2018.1

Capture.JPG

 

In the meantime, please take a look at AXI4-Stream Support in System Generator section (page 98 and onwards)

of https://www.xilinx.com/support/documentation/sw_manuals/xilinx2018_1/ug897-vivado-sysgen-user.pdf

 

0 Kudos
Highlighted
Visitor
Visitor
1,648 Views
Registered: ‎04-18-2018

Thank you so much. I'll try to set them up in the next days!

 

0 Kudos
Highlighted
Visitor
Visitor
1,576 Views
Registered: ‎04-18-2018

I'm sorry but there's no AXI-STREAM Option in System Generator 2018.1 .... so the problem is unresolved.

0 Kudos
Highlighted
1,570 Views
Registered: ‎06-21-2017

Is there an interface option like this?

 

xilinx.com:interface:axis rtl:1.0

 

Use this one. 

0 Kudos
Highlighted
Scholar
Scholar
1,538 Views
Registered: ‎04-26-2012

@enprevo  "I'm sorry but there's no AXI-STREAM Option in System Generator 2018.1 .... so the problem is unresolved."

 

If you are using the SysGen "IP Catalog" export flow, AXI streams will be automatically inferred from gateway names of the form:

  stream_name_tdata

  stream_name_tvalid

  stream_name_tlast

  etc.

 

See page 98 of UG948 2018.1 .

 

-Brian

 

p.s. I've done this successfully using the "IP Catalog" flow in 2016.x and 2017.x,  but haven't personally checked that it is still working in 2018.1.

 

EDIT: Make sure the "Auto Infer Interface" checkbox is selected under System Generator Icon=>Compilation(IP Catalog)=>Settings.

0 Kudos
Highlighted
Participant
Participant
1,498 Views
Registered: ‎09-09-2010

0 Kudos