cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Highlighted
Visitor
Visitor
7,191 Views
Registered: ‎06-22-2009

System Generator 11.1 in linux

Jump to solution

I am trying to use the new Linux functionallity of System Generator, but am running into some issues.

 

Whenever I open a model I get the following errors:

 

Warning: xbsIndex_r4.mdl, line 7: Error evaluating 'PreLoadFcn' callback of block_diagram
'xbsIndex_r4'. Invalid MEX-file
'/net/fpga2/xilinx/11.1/DSP_Tools/lin/sysgen/bin/xlmeta.mexglx':
/net/fpga2/xilinx/11.1/DSP_Tools/lin/sysgen/bin/../lib/libregistrationid.so: undefined
symbol: Sec_Checkin.
> In general/private/openmdl at 13
  In open at 153
  In uiopen at 196
Warning: xbsIndex_r4.mdl, line 7: Invalid MEX-file
'/net/fpga2/xilinx/11.1/DSP_Tools/lin/sysgen/bin/xlmeta.mexglx':
/net/fpga2/xilinx/11.1/DSP_Tools/lin/sysgen/bin/../lib/libregistrationid.so: undefined
symbol: Sec_Checkin.
> In general/private/openmdl at 13
  In open at 153
  In uiopen at 196
Warning: xbsCopyrightNotice_r4.mdl, line 7: Error evaluating 'PreLoadFcn' callback of
block_diagram 'xbsCopyrightNotice_r4'. Invalid MEX-file
'/net/fpga2/xilinx/11.1/DSP_Tools/lin/sysgen/bin/xlmeta.mexglx':
/net/fpga2/xilinx/11.1/DSP_Tools/lin/sysgen/bin/../lib/libregistrationid.so: undefined
symbol: Sec_Checkin.
> In general/private/openmdl at 13
  In open at 153
  In uiopen at 196
Warning: xbsCopyrightNotice_r4.mdl, line 7: Invalid MEX-file
'/net/fpga2/xilinx/11.1/DSP_Tools/lin/sysgen/bin/xlmeta.mexglx':
/net/fpga2/xilinx/11.1/DSP_Tools/lin/sysgen/bin/../lib/libregistrationid.so: undefined
symbol: Sec_Checkin.
> In general/private/openmdl at 13
  In open at 153
  In uiopen at 196

 

If I try to run the model, every System Generator block has the error:

Error evaluation parameter 'ptable_' in [block name]: Undefined function of vriable 'ptable_'

Which means that it is not calling the mask initialization code, which sets 'ptable_'. I suspect that the error opening the model is contributing to that. 

 

I don't think it is a path error, because it can find the mex-file, it just doesn't like it. Linux thinks that it is a valid executable, so I know that the file is not corrupted.

 

I am running CentOS 5.3 (RHEL5.3 clone)

 

Any ideas?

Tags (3)
0 Kudos
1 Solution

Accepted Solutions
Highlighted
Visitor
Visitor
7,687 Views
Registered: ‎06-22-2009

Thanks for suggesting ldd. After running that I realized what the problem was:

$ ldd /net/fpga2/xilinx/11.1/DSP_Tools/lin/sysgen/lib/libregistrationid.so
        linux-gate.so.1 =>  (0x00c13000)
        libpthread.so.0 => /lib/libpthread.so.0 (0x0041c000)
        libSecurity.so => /net/fpga2/xilinx/10.1/ISE/lib/lin/libSecurity.so (0x0027c000)
        libstdc++.so.6 => /net/fpga2/xilinx/10.1/ISE/lib/lin/libstdc++.so.6 (0x00110000)
        libm.so.6 => /lib/libm.so.6 (0x001f0000)
        libc.so.6 => /lib/libc.so.6 (0x00478000)
        libgcc_s.so.1 => /lib/libgcc_s.so.1 (0x00f07000)
        /lib/ld-linux.so.2 (0x0045c000)

 

My paths were still being setup for the 10.1 tools, even though I changed my bashrc to use the 11.1 tools. I couldn't find where I was calling the 10.1 settins script, so I just cleared LD_LIBRARY_PATH before calling the 11.1 script. 

View solution in original post

0 Kudos
4 Replies
Highlighted
Explorer
Explorer
7,185 Views
Registered: ‎09-28-2007

Did you run the settings32.sh / settings32.csh script in the top level directory of your ISE Design Suite installation (/net/fpga2/xilinx/11.1)?

 

Please make sure that the ISE lib directory (/net/fpga2/xilinx/11.1/ISE/lib/lin) is in $LD_LIBRARY_PATH.

 

Ben 

0 Kudos
Highlighted
Visitor
Visitor
7,182 Views
Registered: ‎06-22-2009
I was running the settings file, but did not have ISE 11.1 in the LD_LIBRARY_PATH. Unfortunately, adding it did not seem to solve the problem.
0 Kudos
Highlighted
Explorer
Explorer
7,175 Views
Registered: ‎09-28-2007

What shell are you using? Is your machine a 32-bit or 64-bit machine? Please check if you invoke the right settings script:

 

 

  • 32-bit Linux with bash shell: xilinx/11.1/settings32.sh 
  • 32-bit Linux with csh shell: xilinx/11.1/settings32.csh 
  • 64-bit Linux with bash shell: xilinx/11.1/settings64.sh 
  • 64-bit Linux with csh shell: xilinx/11.1/settings64.csh 

 

 

The script should add xilinx/11.1/ISE/bin/lin or xilinx/11.1/ISE/bin/lin64 to $PATH, and xilinx/11.1/ISE/lib/lin or xilinx/11.1/ISE/lib/lin64 to $LD_LIBRARY_PATH.

 

If you don't see these settings after running the settings script, something wrong happened.

 

As the error message indicates a library dependency issue, you can run ldd to check what's missing.

 

ldd /net/fpga2/xilinx/11.1/DSP_Tools/lin/sysgen/lib/libregistrationid.so 

0 Kudos
Highlighted
Visitor
Visitor
7,688 Views
Registered: ‎06-22-2009

Thanks for suggesting ldd. After running that I realized what the problem was:

$ ldd /net/fpga2/xilinx/11.1/DSP_Tools/lin/sysgen/lib/libregistrationid.so
        linux-gate.so.1 =>  (0x00c13000)
        libpthread.so.0 => /lib/libpthread.so.0 (0x0041c000)
        libSecurity.so => /net/fpga2/xilinx/10.1/ISE/lib/lin/libSecurity.so (0x0027c000)
        libstdc++.so.6 => /net/fpga2/xilinx/10.1/ISE/lib/lin/libstdc++.so.6 (0x00110000)
        libm.so.6 => /lib/libm.so.6 (0x001f0000)
        libc.so.6 => /lib/libc.so.6 (0x00478000)
        libgcc_s.so.1 => /lib/libgcc_s.so.1 (0x00f07000)
        /lib/ld-linux.so.2 (0x0045c000)

 

My paths were still being setup for the 10.1 tools, even though I changed my bashrc to use the 11.1 tools. I couldn't find where I was calling the 10.1 settins script, so I just cleared LD_LIBRARY_PATH before calling the 11.1 script. 

View solution in original post

0 Kudos