cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
jacob.boline
Visitor
Visitor
1,200 Views
Registered: ‎07-28-2017

Use different AXI4-lite clock in system generator

I've built a waveform generator in system generator and I wanted to use a AXI4-Lite interface to set the settings for it. I've set the Implementation Interface on the Xilinx gateway blocks to "AXI4-Lite" which gives me the interface, however it is clocked at the rate of my waveform data generator (250 MHz). Is there anyway I can separate the clocks in system generator so that I can run the AXI4-Lite interface at 150MHz, while I run the waveform generation at 250 MHz? Or will I have to do a custom AXI wrapper over it to take care of this?

 

Thanks.

0 Kudos
3 Replies
balkris
Xilinx Employee
Xilinx Employee
1,149 Views
Registered: ‎08-01-2008

try with multi clock domain

https://www.xilinx.com/video/hardware/system-generator-multiple-clock-domains.html

Thanks and Regards
Balkrishan
--------------------------------------------------------------------------------------------
Please mark the post as an answer "Accept as solution" in case it helped resolve your query.
Give kudos in case a post in case it guided to the solution.
0 Kudos
jacob.boline
Visitor
Visitor
1,143 Views
Registered: ‎07-28-2017

So how would I set this up? Put all the gateways in one clock domain, and everything else in the rest?

0 Kudos
aviblanka71
Observer
Observer
456 Views
Registered: ‎11-21-2018

I have the same challenge, did you have any success?

0 Kudos