cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Highlighted
Visitor
Visitor
10,899 Views
Registered: ‎11-26-2014

Xilinx xfft 8.0 Cmodel Compilation Error

Hi,

 

I am currently trying to compile the example code for the bit accurate cmodel for the Xilinx xfft 8.0 core ip.

The is pointing to the .lib file but when I build the project I get the below errors.

What could be causing this?

 

Thanks,

 

Alex

Capture.JPG

 

0 Kudos
8 Replies
Highlighted
Xilinx Employee
Xilinx Employee
10,880 Views
Registered: ‎08-02-2011

Hello,

Have you tried searching for these types of errors? They are discussed a lot on these forums. :)
www.xilinx.com
0 Kudos
Highlighted
Visitor
Visitor
10,867 Views
Registered: ‎11-26-2014

Thanks,

 

I found this thread http://forums.xilinx.com/t5/Digital-Signal-Processing-IP-and/FFT-C-model-C-simulation-fails-to-compile/m-p/393587#M3697 that solved the problem. I was using a 32bit compiler for the 64bit version.

 

But now I am gettting a different error:

 

error LNK2019: unresolved external symbol __imp___CrtDbgReportW referenced in function "public: char const & __thiscall std::_String_const_iterator<class std::_String_val<struct std::_Simple_types<char> > >::operator*(void)const " (??D?$_String_const_iterator@V?$_String_val@U?$_Simple_types@D@std@@@std@@@std@@QBEABDXZ)    C:\Users\Lab 538A\Desktop\xfft_v8_0_bitacc_cmodel_nt\FFT_CModel32bit\FFT_CModel32bit\run_bitacc_cmodel.obj    FFT_CModel32bit

 

Thanks,

 

Alex

0 Kudos
Highlighted
Visitor
Visitor
10,863 Views
Registered: ‎11-26-2014

Solved:

 

For whatever reason it seems that It has to be compiled in Release mode not debug.

 

 

0 Kudos
Highlighted
Visitor
Visitor
10,856 Views
Registered: ‎11-26-2014

This allowed the program to compile but, now it gets a runtime error.

 

Runtime Error!

 

R6034

An application has made an attempt to laod the C runtime library incorrectly

 

 

-Alex

0 Kudos
Highlighted
Xilinx Employee
Xilinx Employee
10,843 Views
Registered: ‎02-06-2013

Hi

 

Check below link

 

http://forums.xilinx.com/t5/Digital-Signal-Processing-IP-and/FFT-C-model-C-simulation-fails-to-compile/td-p/390775

Regards,

Satish

--------------------------------------------------​--------------------------------------------
Kindly note- Please mark the Answer as "Accept as solution" if information provided is helpful.

Give Kudos to a post which you think is helpful.
--------------------------------------------------​-------------------------------------------
0 Kudos
Highlighted
Visitor
Visitor
10,836 Views
Registered: ‎11-26-2014

Thanks for the reply,

 

The solution in that post says we need to be in Release mode and that embed manifest needs to be set to yes. I have verified that these settings are correct and the problem still persists.

 

-Alex

 

 

0 Kudos
Highlighted
Visitor
Visitor
10,810 Views
Registered: ‎11-26-2014

I also get an error if MSVCp90.dll or stlport.5.1.dll are not in the same directory as the executable.

0 Kudos
Highlighted
Xilinx Employee
Xilinx Employee
10,693 Views
Registered: ‎08-02-2011

Hello Alex,

Oh sorry, I think this thread will help:
http://forums.xilinx.com/t5/DSP-Tools/Xilinx-FFT-C-Model-and-Windows-7-64-bit-not-working/td-p/282252
www.xilinx.com
0 Kudos