cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Visitor
Visitor
2,705 Views
Registered: ‎06-05-2010

how can i make modelsim co-simulation in System generator

My SG version is 11.3,and modelsim SE is 6.5,when i attempt to use Modesim block in my design,it gives message as below:

 

An internal error occurred in the Xilinx Blockset Library.
Please report this error to Xilinx (http://support.xilinx.com), in as much detail as possible. You may also find immediate help in the Answers Database and other online resources at http://support.xilinx.com.
Error occurred during "Simulation Initialization".

An internal error occurred in the Xilinx Blockset Library.
Please report this error to Xilinx (http://support.xilinx.com), in as much detail as possible. You may also find immediate help in the Answers Database and other online resources at http://support.xilinx.com.

Error occurred during "Simulation Initialization".

 

The detail is: when I run simulation,modesim has  open,and signal names begin to list in the wave window ,but it always running(look the running time in lower left of the modelsim ) but there is no wave in wave window.

modesim.JPG
0 Kudos
1 Reply
Xilinx Employee
Xilinx Employee
2,672 Views
Registered: ‎08-07-2007

Re: how can i make modelsim co-simulation in System generator

Make sure that your HDL code compiles outside of SysGen HDL co-sim with Modelsim.  i.e. can you simulate your hdl file in ModelSim standalone?  Also you can double check that your code meets the requirements listed for an HDL black box in SysGen documented in the User Guide.

 

Another thing to check is if your model will simulate using ISIM as the simulator of choice for your black box and if it will simulate without the black box in there at all.

0 Kudos