cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Observer
Observer
5,199 Views
Registered: ‎10-07-2009

hwcosim error. Dictionary key: "empty"

Hello,

 

I've been at this for a while now and nothing seems to work.

I'm not entirely sure if it was a change in ISE version or IP cores but I start getting this error every time I try to generate an HWcosim for the ML605.

 

---------------------------------------------------------------------

Begin generation

Checking model status

Checking simulation times

Performing compilation and generation Compilation and generation completed in 54.4601 seconds

ERROR:HWCoSim - Failed to find Dictionary key: "empty"

 

*** ERROR ***

 

Hardware co-simulation compilation failed. Failed to find Dictionary key: "empty"

 

--------------------------------------------------------------------

 

Already reinstalled Windows, ISE and Matlab.

No changes :(

 

Would appreciate any help.

 

Cheers,

 

Tiago

0 Kudos
5 Replies
Highlighted
Observer
Observer
5,193 Views
Registered: ‎10-07-2009

Re: hwcosim error. Dictionary key: "empty"

If I change the compilation target to my XtremeDSP Kit-IV I get a different error saying:

Netlist is empty after trimming useless hardware

0 Kudos
Highlighted
Xilinx Employee
Xilinx Employee
5,168 Views
Registered: ‎11-28-2007

Re: hwcosim error. Dictionary key: "empty"

I can't run your model because it doesn't have the initilization of coefficients for the FIR comipler. Anyway, that's not the casue of the error you're getting. I think the problem is that you turned off all gateway out blocks in your model. To turn on a gateway out, you need to check the "Translate Into Output Port" option and the block will now have a yellow background. When it's off, it has the gray background.

 

ScreenHunter_06.jpg

 

 


@fruntxas wrote:

Hello,

 

I've been at this for a while now and nothing seems to work.

I'm not entirely sure if it was a change in ISE version or IP cores but I start getting this error every time I try to generate an HWcosim for the ML605.

 

---------------------------------------------------------------------

Begin generation

Checking model status

Checking simulation times

Performing compilation and generation Compilation and generation completed in 54.4601 seconds

ERROR:HWCoSim - Failed to find Dictionary key: "empty"

 

*** ERROR ***

 

Hardware co-simulation compilation failed. Failed to find Dictionary key: "empty"

 

--------------------------------------------------------------------

 

Already reinstalled Windows, ISE and Matlab.

No changes :(

 

Would appreciate any help.

 

Cheers,

 

Tiago




Cheers,
Jim
0 Kudos
Highlighted
Observer
Observer
5,157 Views
Registered: ‎10-07-2009

Re: hwcosim error. Dictionary key: "empty"

First of all sorry about the double topic interaction. It was related, but I'll stick to this one.

 

The problem didn't seem to be the "Gateway Out".

I'll attach another design without the Interpolation where I set the Gateways as you asked and I still get the same error.

 

Apparently the trick is to create a custom compilation target that targets the Virtex6 xc6vlx240t-1ff1156.

With the custom compilation target with a differential clock of 200 MHz I can reach the hwcosim library block I'm looking for.
Will try to test it during the afternoon to see if it works correctly.

 

Even so, using the default compilation target for reference designs that come with the Ml605 seems to work 

0 Kudos
Highlighted
Observer
Observer
5,125 Views
Registered: ‎10-07-2009

Re: hwcosim error. Dictionary key: "empty"

Any one? :x

0 Kudos
Highlighted
Observer
Observer
5,075 Views
Registered: ‎10-07-2009

Re: hwcosim error. Dictionary key: "empty"

Was using ISE 13.1

 

ISE 13.3 seems to solve the problem.

Also uninstalled all Java-related crap I had.

 

The dictionary key ERROR doesn't show up anymore :D

0 Kudos