cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
shairva
Explorer
Explorer
635 Views
Registered: ‎09-19-2018

Vitis AI model zoo: NO FRONT END SPECIFIED

Jump to solution

Hi,

I want to compile compile the caffe model for the resnet50 application, as described here.

 

(vitis-ai-caffe) salva@salva-kubuntu:/workspace/DPU-TRD-ULTRA96V2/modelzoo$ source ./compile_cf_model.sh resnet50 cf_resnet50_imagenet_224_224_7.7G
**************************************************
* VITIS_AI Compilation - Xilinx Inc.
**************************************************
**************************************************
*  NO FRONT END SPECIFIED
**************************************************
(vitis-ai-caffe) salva@salva-kubuntu:/workspace/DPU-TRD-ULTRA96V2/modelzoo$ 

 

 

  • compile_cf_model.sh:

 

(vitis-ai-caffe) salva@salva-kubuntu:/workspace/DPU-TRD-ULTRA96V2/modelzoo$ cat compile_cf_model.sh 
model_name=$1
modelzoo_name=$2
vai_c_caffe \
--prototxt ../../AI-Model-Zoo/models/${modelzoo_name}/quantized/deploy.prototxt \
--caffemodel ../../AI-Model-Zoo/models/${modelzoo_name}/quantized/deploy.caffemodel \
--arch ./custom.json \
--output_dir ./compiled_output/${modelzoo_name} \
--net_name ${model_name} \
--options "{'mode': 'normal'}"

(vitis-ai-caffe) salva@salva-kubuntu:/workspace/DPU-TRD-ULTRA96V2/modelzoo$ 

 

 

  • custom.json:

 

(vitis-ai-caffe) salva@salva-kubuntu:/workspace/DPU-TRD-ULTRA96V2/modelzoo$ cat custom.json
{"target": "dpuv2", "dcf": "./ULTRA96V2.dcf", "cpu_arch": "arm64"}
(vitis-ai-caffe) salva@salva-kubuntu:/workspace/DPU-TRD-ULTRA96V2/modelzoo$ 

 

 

The solution provided here did not solve this problem to me. 

0 Kudos
1 Solution

Accepted Solutions
shairva
Explorer
Explorer
622 Views
Registered: ‎09-19-2018

Solution:

Taking a look to the file 

config_file/prj_config

I can see that the name of the DPU is DPUCZDX8G instead of dpuv2. 

So at custom.json, I just changed and the problem was solved.

 

View solution in original post

2 Replies
shairva
Explorer
Explorer
623 Views
Registered: ‎09-19-2018

Solution:

Taking a look to the file 

config_file/prj_config

I can see that the name of the DPU is DPUCZDX8G instead of dpuv2. 

So at custom.json, I just changed and the problem was solved.

 

View solution in original post

Hikaru_Furuta
Visitor
Visitor
331 Views
Registered: ‎12-15-2020

I suffered the same error. After quantizing models, had an error, NO FRONT END SPECIFIED.

Could you tell me what you had used as $1 and $2? In my situation, defined $1 and $2 as 'ResNet' and './' respectively.

0 Kudos