cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
louisli
Observer
Observer
849 Views
Registered: ‎05-21-2014

failed to install decent

Jump to solution

Hi,

I am working under the user guide of the DNNDK.

I can see that DNNC is installed successfully.

$ dnnc --version
dnnc version v2.04
DPU Target : v1.4.0
Build Label: Apr 24 2019 19:12:00
Copyright @2019 Xilinx Inc. All Rights Reserved.

However, there is a problem when I tried to install the Deep Compression Tool (DECENT). The command and error can be seen below.

$ decent --version
decent: error while loading shared libraries: libcudart.so.9.0: cannot open shared object file: No such file or directory

Can you please help me check this issue? Thank you!

regards,

Louis

0 Kudos
1 Solution

Accepted Solutions
lvalena
Xilinx Employee
Xilinx Employee
816 Views
Registered: ‎12-09-2015

(^^)/

 

Searching with "ubuntu install cuda" will provide many hits, one of which may be:

 

Install NVIDIA CUDA 9.0 on Ubuntu 16.04.4 LTS

 

 

View solution in original post

0 Kudos
4 Replies
lvalena
Xilinx Employee
Xilinx Employee
826 Views
Registered: ‎12-09-2015

(^^)/

 

The message "error while loading shared libraries: libcudart.so.9.0" indicates that a CUDA library is missing. Please see UG1327 (v1.4) p. 8:

 

Capture.PNG

Capture.PNG

 

You may try using your favorite search engine to look for instructions on how to install CUDA and cuDNN using the keywords "install cudnn".

 

0 Kudos
louisli
Observer
Observer
819 Views
Registered: ‎05-21-2014

Hi,

Thanks for your detailed reply!

I have thought about this possibility. However, it seems that I have already installed the required packages. Below is the command and information when I was trying to install DECENT and DNNC.

$ sudo ./install.sh ZCU102
Inspect system environment ...
[system version]
16.04
[CUDA version]
9.0
[CUDNN version]
7.0.5
Begin to install Xilinx DNNDK tools on host ...
Complete dnnc installation successfully.
Complete CPU version of decent for caffe installation successfully.
Complete GPU version of decent installation successfully.

I have used the following commands to check the CUDA and cuDNN version. Any idea on what is the problem?

$ cat /usr/local/cuda/version.txt

CUDA Version 9.0.176

$ cat /usr/local/cuda/include/cudnn.h | grep CUDNN_MAJOR -A 2
#define CUDNN_MAJOR 7
#define CUDNN_MINOR 0
#define CUDNN_PATCHLEVEL 5
--
#define CUDNN_VERSION (CUDNN_MAJOR * 1000 + CUDNN_MINOR * 100 + CUDNN_PATCHLEVEL)

#include "driver_types.h"

0 Kudos
lvalena
Xilinx Employee
Xilinx Employee
817 Views
Registered: ‎12-09-2015

(^^)/

 

Searching with "ubuntu install cuda" will provide many hits, one of which may be:

 

Install NVIDIA CUDA 9.0 on Ubuntu 16.04.4 LTS

 

 

View solution in original post

0 Kudos
tongtyr
Observer
Observer
650 Views
Registered: ‎07-02-2019

Have you solved this problem?

I met the same problem,too.

0 Kudos