cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
YilinChen
Visitor
Visitor
374 Views
Registered: ‎10-31-2020

run "./docker_build_gpu.sh" without "su root", but because of permission related issues, it failed

hi, guys

i just try to run "./docker_build_gpu.sh" without "su root", but because of permission related issues, it failed like this

Screenshot from 2020-11-05 16-08-47.png

but as shown below, i can run "docker run hello-world" without sudo

Screenshot from 2020-11-05 13-40-52.png

is there anyone who can help me to deal with this problem?

appreciating for any help, thanks

0 Kudos
4 Replies
zhijiexu
Moderator
Moderator
361 Views
Registered: ‎09-29-2020

hi, @YilinChen 

For you question post above, I believe you can try to use command " sudo ./docker_build_gpu.sh" to install the docker-gpu, then use command to make you become a no-root user.

thanks,

zhijie

 

YilinChen
Visitor
Visitor
359 Views
Registered: ‎10-31-2020

okay, i will follow your instructions and try it again, thanks

0 Kudos
YilinChen
Visitor
Visitor
339 Views
Registered: ‎10-31-2020

hi, zhijiexu

i just try to run "sudo ./docker_build_gpu.sh", but the result is same to "./docker_build_gpu.sh"

and after i try to run shells like these in an VPN connected environment

Screenshot from 2020-11-05 17-50-30.png

the output is shown below

Screenshot from 2020-11-05 18-00-35.png

and after i disconnect VPN and run "./docker_build_gpu.sh" under "su root" shown below

Screenshot from 2020-11-05 18-04-07.png

it seemed like the installation is on the way

Screenshot from 2020-11-05 18-10-24.png

and there will be a long-waiting-process, after nearly an hour, the output is shown below

Screenshot from 2020-11-05 18-50-27.png

how weird it is!

how weird it is!

how weird it is!

0 Kudos
watari
Teacher
Teacher
270 Views
Registered: ‎06-16-2013

Hi @YilinChen 

 

From your log, it seems DNS issue.

So, would you make sure resolver setting ?

I suggest you to make sure resolver setting and status by the following command on the host machine.

 

$ dig www.xilinx.com

 

Would you try it ?

 

Best regards,