cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
lixiaocui
Visitor
Visitor
568 Views
Registered: ‎06-07-2020

vai_q_tensorflow error

Jump to solution

i got my mobilenet_v1.pb following the flow in tensorflow/models/reasearch/slim(https://github.com/tensorflow/models/tree/master/research/slim), my tensorflow version is 1.15. But when I try to quantize the frozen graph, I got the error below:

ValueError: NodeDef mentions attr 'explicit_paddings' not in Op<name=Conv2D; signature=input:T, filter:T -> output:T; attr=T:type,allowed=[DT_HALF, DT_BFLOAT16, DT_FLOAT, DT_DOUBLE]; attr=strides:list(int); attr=use_cudnn_on_gpu:bool,default=true; attr=padding:string,allowed=["SAME", "VALID"]; attr=data_format:string,default="NHWC",allowed=["NHWC", "NCHW"]; attr=dilations:list(int),default=[1, 1, 1, 1]>; NodeDef: {{node MobilenetV1/MobilenetV1/Conv2d_0/Conv2D}} = Conv2D[T=DT_FLOAT, data_format="NHWC", dilations=[1, 1, 1, 1], explicit_paddings=[], padding="SAME", strides=[1, 2, 2, 1], use_cudnn_on_gpu=true](input, MobilenetV1/Conv2d_0/weights/read). (Check whether your GraphDef-interpreting binary is up to date with your GraphDef-generating binary.).

Does anyone know what's the problem?

 

0 Kudos
1 Solution

Accepted Solutions
jasonwu
Moderator
Moderator
461 Views
Registered: ‎03-27-2013

Hi @lixiaocui ,

 

I did a quick search on internet and it seems that someone else met the simiar issue it is more like a version mismatch issue:

https://github.com/migueldeicaza/TensorFlowSharp/issues/451

 

 

Best Regards,
Jason
-----------------------------------------------------------------------------------------------
Please mark the Answer as "Accept as solution" if the information provided is helpful.

Give Kudos to a post which you think is helpful and reply oriented.
-----------------------------------------------------------------------------------------------

View solution in original post

0 Kudos
1 Reply
jasonwu
Moderator
Moderator
462 Views
Registered: ‎03-27-2013

Hi @lixiaocui ,

 

I did a quick search on internet and it seems that someone else met the simiar issue it is more like a version mismatch issue:

https://github.com/migueldeicaza/TensorFlowSharp/issues/451

 

 

Best Regards,
Jason
-----------------------------------------------------------------------------------------------
Please mark the Answer as "Accept as solution" if the information provided is helpful.

Give Kudos to a post which you think is helpful and reply oriented.
-----------------------------------------------------------------------------------------------

View solution in original post

0 Kudos