cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
437 Views
Registered: ‎02-10-2020

Alveo U200 XRT set up failure

Hello, 

I recently started doing research that requires the Alveo U200 Data Accelerator card and had to update XRT in order to use it with the new VITIS framework. After installing XRT and the following packages: 

I followed UG1301's guide 

https://www.xilinx.com/support/documentation/boards_and_kits/accelerator-cards/1_4/ug1301-getting-started-guide-alveo-accelerator-cards.pdf

currently I am on the document's page 22 I have follow the steps exactly. However during installation after installing:

1. XRT

xrt_201920.2.5.309_7.4.1708-x86_64-xrt.rpm

2. and then installing target platform

  xilinx-U200-xdma-201830.2-2580015.x86_64.rpm

3. and the dev platform since I am building on the board:

xilinx-U200-xdma-dev-201830.2-2580015.x86_64.rpm

 

I noticed I did NOT get the message: 

DSA package installed successfully. Please flash card manually by running below command: sudo /opt/xilinx/xrt/bin/xbmgmt flash --update --shell

 

When I try and run "xbutil validate" this is the error message I get: (it's this message for any xrt command i try and use via CLI)

 

ERROR: Mixed versions of XRT and xbutil are not supported.             
Please install matching versions of XRT and xbutil or              
define env variable INTERNAL_BUILD to disable this check

 

 

this is what /opt/xilinx/xrt/bin looks like:

mpd  plp_program.sh  xbmgmt2  xbutil   xclbincat    xclbinutil
msd  xbmgmt          xbsak    xbutil2  xclbinsplit  xrtdeps.sh

When I run:

echo $PLATFORM_REPO_PATHS

i get a blank line telling me my paths don't exist.

 

this is already after I ran

vivado

start gui 

knowing that vivado does a lot of configuring when you run it. that critically failed and now I no longer have vivado with the message:

CRITICAL WARNING: [Common 17-183] Failed to open handle vivado.jou. Please check access permission of directory '/opt/xilinx/xrt/bin'. You should restart the application from a writable working directory.
CRITICAL WARNING: [Common 17-183] Failed to open handle vivado.log. Please check access permission of directory '/opt/xilinx/xrt/bin'. You should restart the application from a writable working directory.

So now I am also locked out of Vivado, as the gui never loads.

I did run 

source /tools/Xilinx/Vitis/2019.2/settings64.sh

and

source /opt/xilinx/xrt/setup.sh

 both of which work and the former even gives me pathing. 

 

I previously had xrt working on the machine and was able to make and compile with guidance from https://github.com/Xilinx/Get_Moving_With_Alveo  however it failed with linking and I was told to update the FPGA platform since that's what it was validated with and that's how I got here. 

 

Any help is extremely apprecaited. 

Thank you for taking the time to read this!

 

 

Tags (1)
0 Kudos
Reply
1 Reply
mcertosi
Xilinx Employee
Xilinx Employee
397 Views
Registered: ‎10-19-2015

Hi cwjohnson@sdsu.edu 

Two of the most common install issues: Did you re-run the xrt dependency script and did you run the python checking script? 

They are both located here: https://github.com/Xilinx/XRT/tree/master/src/runtime_src/tools/scripts you want to run  xrtdeps.sh and pyopencl_install_check.sh 

Did you remove XRT from the system before upgrading? $sudo yum remove xrt

After that, try the process again. If it still fails, can you attach a printout of the install log? 

Thanks,

M

 

-------------------------------------------------------------------------
Don’t forget to reply, kudo, and accept as solution.
-------------------------------------------------------------------------
0 Kudos
Reply