cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
chicagomichael
Visitor
Visitor
299 Views
Registered: ‎03-23-2021

My Device(Alveo u200)'s openCL version 1.0?

Jump to solution

My Device(Alveo u200) "Device OpenCL C Version OpenCL C 1.0". Is this OK?

My OS is ubumtu 16.04.

And openCL is "ocl-icd-libopencl1 is already the newest version (2.2.8-1)".

 

$ clinfo

Number of platforms 1

Platform Name Xilinx

Platform Vendor Xilinx

Platform Version OpenCL 1.0

Platform Profile EMBEDDED_PROFILE

Platform Extensions cl_khr_icd

Platform Extensions function suffix

 

Platform Name Xilinx

Number of devices 1

Device Name xilinx_u200_xdma_201830_2

Device Vendor Xilinx

Device Vendor ID 0x0

Device Version OpenCL 1.0

Driver Version 1.0

Device OpenCL C Version OpenCL C 1.0

Device Type Accelerator

Device Profile EMBEDDED_PROFILE

Max compute units 0

Max clock frequency 500MHz

Max work item dimensions 3

Max work item sizes 4294967295x4294967295x4294967295

Max work group size 4294967295

0 Kudos
1 Solution

Accepted Solutions
JohnFedakIV
Moderator
Moderator
253 Views
Registered: ‎09-04-2020

Hi @chicagomichael ,

Welcome to the Xilinx Forums!

Yes this is OK and is the same output as the U200 in our lab.

Regards,
~John

----------------------------------------------------------------------------------
* Please don't forget to reply, kudo and accept as a solution! *

View solution in original post

2 Replies
JohnFedakIV
Moderator
Moderator
254 Views
Registered: ‎09-04-2020

Hi @chicagomichael ,

Welcome to the Xilinx Forums!

Yes this is OK and is the same output as the U200 in our lab.

Regards,
~John

----------------------------------------------------------------------------------
* Please don't forget to reply, kudo and accept as a solution! *

View solution in original post

uplin
Visitor
Visitor
110 Views
Registered: ‎09-08-2020

Is the Alveo U200 support OpenCL 1.2 or higher?

0 Kudos