cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
steven_shi
Observer
Observer
862 Views
Registered: ‎09-02-2019

Problem reverting to golden in vcu1525

Jump to solution
 

I followed the AR#71757 instruction, after that xrt can not found the board. My board is VCU1525.

sudo lspci -vd 10ee:
[sudo] password for forest:
01:00.0 Processing accelerators: Xilinx Corporation Device 6a8f
Subsystem: Xilinx Corporation Device 4353
Flags: fast devsel
Memory at f4000000 (32-bit, non-prefetchable) [disabled] [size=32M]
Memory at f6000000 (32-bit, non-prefetchable) [disabled] [size=128K]
Capabilities: [40] Power Management version 3
Capabilities: [60] MSI-X: Enable- Count=33 Masked-
Capabilities: [70] Express Endpoint, MSI 00
Capabilities: [100] Advanced Error Reporting
Capabilities: [1c0] #19
Capabilities: [400] Access Control Services

01:00.1 Processing accelerators: Xilinx Corporation Device 6a90
Subsystem: Xilinx Corporation Device 4353
Flags: fast devsel, IRQ 255
Memory at f2000000 (32-bit, non-prefetchable) [disabled] [size=32M]
Memory at f6020000 (32-bit, non-prefetchable) [disabled] [size=64K]
Capabilities: [40] Power Management version 3
Capabilities: [60] MSI-X: Enable- Count=33 Masked-
Capabilities: [70] Express Endpoint, MSI 00
Capabilities: [100] Advanced Error Reporting
Capabilities: [400] Access Control Services

forest@forest:/opt/xilinx/xrt/bin$ xbutil scan
ERROR: No card found


Does the attachment gloden *.mcs of AR#71757 support KCU1525? If not , where can I find the *.mcs for KCU1525?
0 Kudos
1 Solution

Accepted Solutions
mcertosi
Xilinx Employee
Xilinx Employee
837 Views
Registered: ‎10-19-2015

Hi @steven_shi 

The device ID of what is showing up in LSPCI is a KCU1500. Xilinx Corporation Device 6a90

The drivers are not attached to your PCIe IP, so the card will not show up with xbutil scan 

I don't believe the golden image fallback was tested with the kcu1500 so I'm not sure if AR#71757 will work for you. Additionally, the golden image is for the U2xx series FPGA parts so I can't see them being compatible. 

What are you trying to do? 

Here is the documentation for the kcu1500:

hthttps/wwwwwixilinxom/support/documentation/boards_and_kits/kckcu1500gug1260ckcu1500ata-center.pdf 

In the documentation above, the section "Step 4: Program the Base Platform " has directions on where the .mcs file is and how to use it. 

Can you look at those and let me know if you are still stuck? 

Regards,

M

-------------------------------------------------------------------------
Don’t forget to reply, kudo, and accept as solution.
-------------------------------------------------------------------------

View solution in original post

0 Kudos
4 Replies
mcertosi
Xilinx Employee
Xilinx Employee
838 Views
Registered: ‎10-19-2015

Hi @steven_shi 

The device ID of what is showing up in LSPCI is a KCU1500. Xilinx Corporation Device 6a90

The drivers are not attached to your PCIe IP, so the card will not show up with xbutil scan 

I don't believe the golden image fallback was tested with the kcu1500 so I'm not sure if AR#71757 will work for you. Additionally, the golden image is for the U2xx series FPGA parts so I can't see them being compatible. 

What are you trying to do? 

Here is the documentation for the kcu1500:

hthttps/wwwwwixilinxom/support/documentation/boards_and_kits/kckcu1500gug1260ckcu1500ata-center.pdf 

In the documentation above, the section "Step 4: Program the Base Platform " has directions on where the .mcs file is and how to use it. 

Can you look at those and let me know if you are still stuck? 

Regards,

M

-------------------------------------------------------------------------
Don’t forget to reply, kudo, and accept as solution.
-------------------------------------------------------------------------

View solution in original post

0 Kudos
steven_shi
Observer
Observer
818 Views
Registered: ‎09-02-2019

Hi @mcertosi Followed the doucument you sent to me. The host can detect the board, but still failed at verify stage.

xbsak listxbsak listverifyverify

0 Kudos
mcertosi
Xilinx Employee
Xilinx Employee
800 Views
Registered: ‎10-19-2015

Hi @steven_shi 

Can you double check that the directory you are calling verify from is write enabled? 

Can you provide a path to the xclbin? 

./verify.exe ./verify.xclbin

 Can you provide dmesg if it fails again? 

Regards,

M

-------------------------------------------------------------------------
Don’t forget to reply, kudo, and accept as solution.
-------------------------------------------------------------------------
0 Kudos
steven_shi
Observer
Observer
765 Views
Registered: ‎09-02-2019

Hi @mcertosi

Thanks for your help! I already found the root cause there was no DDR on the board.

0 Kudos