cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
vconst89
Adventurer
Adventurer
411 Views
Registered: ‎09-10-2020

U50, Vivado flow

Jump to solution

Hi there,

I'm using U50 card in the "Alveo Flow", so I configure the board through PCIe bus with the relevant shell and then load kernels,

Now I want to try this board in PCIE+Ethernet mode and so I got the reference design xilinx_u50_qsfp_v1_0 xpr, but how should I configure FPGA now?

Should I also buy Xilinx platform cable?https://www.xilinx.com/products/boards-and-kits/hw-usb-ii-g.html

But is it compatible with U50 card? I haven't seen this port on the board. And how should I revert back to shell-mode, with the ability to program the card with  xbmgmt? 

 

vconst89_0-1604311321635.png

 

0 Kudos
1 Solution

Accepted Solutions
JohnFedakIV
Moderator
Moderator
348 Views
Registered: ‎09-04-2020

Hi @vconst89 ,

You are correct that you need the Alveo Programming Cable found on the Alveo Accessories page:

https://www.xilinx.com/products/boards-and-kits/alveo/accessories.html

There is an Answer Record for General Information and Known Issues using the Vivado/Custom flow here:

https://www.xilinx.com/support/answers/71754.html

On that page, one of the answer records discusses different ways to revert the card back to the factory/golden image (about halfway down) which will make the card visible to XRT again:

https://www.xilinx.com/support/answers/71757.html

I would also like to highlight that there is a User Guide for this found in the Alveo Vivado Secure Site.

Regards,
~John

----------------------------------------------------------------------------------
* Please don't forget to reply, kudo and accept as a solution! *

View solution in original post

2 Replies
vconst89
Adventurer
Adventurer
391 Views
Registered: ‎09-10-2020
0 Kudos
JohnFedakIV
Moderator
Moderator
349 Views
Registered: ‎09-04-2020

Hi @vconst89 ,

You are correct that you need the Alveo Programming Cable found on the Alveo Accessories page:

https://www.xilinx.com/products/boards-and-kits/alveo/accessories.html

There is an Answer Record for General Information and Known Issues using the Vivado/Custom flow here:

https://www.xilinx.com/support/answers/71754.html

On that page, one of the answer records discusses different ways to revert the card back to the factory/golden image (about halfway down) which will make the card visible to XRT again:

https://www.xilinx.com/support/answers/71757.html

I would also like to highlight that there is a User Guide for this found in the Alveo Vivado Secure Site.

Regards,
~John

----------------------------------------------------------------------------------
* Please don't forget to reply, kudo and accept as a solution! *

View solution in original post