UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Visitor busa2112
Visitor
14,840 Views
Registered: ‎08-12-2014

Invalid device driver license. Cable connection failed.

After installing the Registration ID provided to me by Xilinx Customer Service, the program works for 30 days then stops.  I never had this problem with the original RegID.  There is NO warning before, during or after the install that this will expire. 

 

The message I get is-

 

Connecting to cable (Usb Port - USB21).

Checking cable driver. 

 Driver version: 1027 (1027).
 Driver windrvr6.sys version = 8.1.1.0. WinDriver v8.11 Jungo (c) 1997 - 2006 Build Date: Oct 16 2006 X86 32bit SYS 12:35:07, version = 811.
Invalid device driver license.

Cable connection failed.

 

 -Please Help -

jtag_error.bmp
0 Kudos
23 Replies
Xilinx Employee
Xilinx Employee
14,825 Views
Registered: ‎02-16-2014

Re: Invalid device driver license. Cable connection failed.

Hi,

 

In which ISE version you are seeing this issue and on which OS?

 

There was a known issue in ISE 9.2 running on windows Vista.

0 Kudos
Xilinx Employee
Xilinx Employee
14,824 Views
Registered: ‎04-16-2012

Re: Invalid device driver license. Cable connection failed.

Hi,

Which version of impact are you using?
Can you try reinstalling the drivers by following the steps mentioned in UG344: http://www.xilinx.com/support/documentation/user_guides/ug344.pdf

Thanks,
Vinay
--------------------------------------------------------------------------------------------
Have you tried typing your question in Google? If not you should before posting. Also, MARK this is as an answer in case it helped resolve your query/issue.Give kudos to the post that helped you to find the solution.
0 Kudos
Visitor busa2112
Visitor
14,817 Views
Registered: ‎08-12-2014

Re: Invalid device driver license. Cable connection failed.

Windows 7 x86  Enterprise edition.  ISE 10.1  _impact.exe is dated 2008 and is 13kb or 13,312 bytes

I can try reinstalling the drivers per the link you mentioned but does the fact that every 30 days on the dot, like clockwork,  it fails with the same license message indicate a licensing issue?  I saw several issues and recommendations in the FAQ licensing section but didn't try any of them in hopes of getting a silver bullet, "duh, that's an easy answer, I can't believe he asked that"  fix,  rather than a shotgun response of try this, try that, hop through these hoops, did that work?  (fingers crossed) troubleshooting.  Forgive my frustration but I've spent many hours on this as well as Stopping Production on our line because of it.   Please advise.

 

Regards

 

0 Kudos
Newbie rockli
Newbie
13,687 Views
Registered: ‎04-15-2015

Re: Invalid device driver license. Cable connection failed.

Hi guy, have you found the resolution for this issue? I met the same issue as you. It works well days ago, but one  day suddenly it stops works with the same phenomenon as you described. This issue blocks me for two days. so frustrating :(

0 Kudos
Newbie mvg
Newbie
13,204 Views
Registered: ‎06-30-2015

Re: Invalid device driver license. Cable connection failed.

Hello,

I have the same issue today. Some days ago the tool worked!

Could you please advise me anything?

 

Thanks!

0 Kudos
12,676 Views
Registered: ‎12-18-2013

Re: Invalid device driver license. Cable connection failed.

Have you perhaps recently installed Vivado?
If that's the case, try installing ISE again.

 

0 Kudos
12,642 Views
Registered: ‎12-18-2013

Re: Invalid device driver license. Cable connection failed.

To clarify:
In my case, this driver problem started after I installed Vivado on the same machine I used to use ISE on,
A coworker of mine had exactly the same problem. After he uninstalled, and then re-installed ISE, everything worked again for him.
For some reason this didn't work for me.
However, after I ran the install_drivers.exe program, everything worked again.

So, here is my suggestion:


- Find the install_drivers.exe program in the Xilinx directory tree: in my case it was in 
   C:\Xilinx\14.7\ISE_DS\ISE\bin\nt64   (\nt if you're on a 32 bit machine)

- Open a 'dos box' as administrator(!), and cd to the above directory

- run 'install_drivers.exe'

 

Let us know if this works for you as well!

0 Kudos
Newbie maxomicron
Newbie
12,619 Views
Registered: ‎09-08-2015

Re: Invalid device driver license. Cable connection failed.

Hi, i have the same problem (error message) as below.

But in my case it happens after i was on vacation for 1 Week.  I came back and this error message appears..

i've tryed every single "solution" but (driver reinstall in serveral ways (windrvr6.inf, install_driver.exe...)) Additional Install the LabTools and their cable driver...

 

In my opinion the hint is " Invalid device driver license". So i dont think that a full reinstall of ise could solve the problem.

 

But i have no idea what the solution is...

 

I lost  a day trying to fix the problem, but nothing helped..

 

there must be a person who can help me!? :)

 

 

 

0 Kudos
Newbie maxomicron
Newbie
12,615 Views
Registered: ‎09-08-2015

Re: Invalid device driver license. Cable connection failed.

ive reinstalled ISE,but still the same error.. :

 

 

GUI --- Auto connect to cable...
INFO:iMPACT - Digilent Plugin: Plugin Version: 2.4.4
INFO:iMPACT - Digilent Plugin: no JTAG device was found.
AutoDetecting cable. Please wait.
*** WARNING ***: When port is set to auto detect mode, cable speed is set to default 6 MHz regardless of explicit arguments supplied for setting the baud rates
PROGRESS_START - Starting Operation.
Connecting to cable (Usb Port - USB21).
Checking cable driver.
 Driver file xusbdfwu.sys found.
 Driver version: src=1027, dest=1027.
 Driver windrvr6.sys version = 11.5.0.0. WinDriver v11.5.0 Jungo Connectivity (c) 1997 - 2014 Build Date: Jan 26 2014 x86_64 64bit SYS 13:30:18, version = 1150.
Invalid device driver license.
Cable connection failed.
Connecting to cable (Parallel Port - LPT1).
Checking cable driver.
 Driver windrvr6.sys version = 11.5.0.0. WinDriver v11.5.0 Jungo Connectivity (c) 1997 - 2014 Build Date: Jan 26 2014 x86_64 64bit SYS 13:30:18, version = 1150.
Cable connection failed.
Connecting to cable (Parallel Port - LPT2).
Checking cable driver.
 Driver windrvr6.sys version = 11.5.0.0. WinDriver v11.5.0 Jungo Connectivity (c) 1997 - 2014 Build Date: Jan 26 2014 x86_64 64bit SYS 13:30:18, version = 1150.
Cable connection failed.
Connecting to cable (Parallel Port - LPT3).
Checking cable driver.
 Driver windrvr6.sys version = 11.5.0.0. WinDriver v11.5.0 Jungo Connectivity (c) 1997 - 2014 Build Date: Jan 26 2014 x86_64 64bit SYS 13:30:18, version = 1150.
Cable connection failed.
Connecting to cable (Parallel Port - LPT4).
Checking cable driver.
 Driver windrvr6.sys version = 11.5.0.0. WinDriver v11.5.0 Jungo Connectivity (c) 1997 - 2014 Build Date: Jan 26 2014 x86_64 64bit SYS 13:30:18, version = 1150.
Cable connection failed.
PROGRESS_END - End Operation.
Elapsed time =      2 sec.
Cable autodetection failed.
WARNING:iMPACT:923 - Can not find cable, check cable setup !

....

0 Kudos
Newbie maxomicron
Newbie
16,702 Views
Registered: ‎09-08-2015

Re: Invalid device driver license. Cable connection failed.

hey guys..

 

i've got it! Finally!

 

I uninstalled the Jungo Driver via Device-Manager. After that i restartet my Pc and

changed to the system folder : C:\Windows\System32\drivers and deletet the windrvr6.sys file.

After that i was going to C:\Xilinx\14.7\ISE_DS\ISE\bin\nt64 (64Bit ) or C:\Xilinx\14.7\ISE_DS\ISE\bin\nt (32Bit) and excecuted the "install_driver.exe" with admin permissions.

 

Finally the windrvr6.sys file in the Sytem32\drivers folder has an  last change date "2013-10-13". Beforre it was something in 2014...

 

I don't know if this helps permanent or only for the next 30 Days (of Trial windriver) but it seems to work!

 

Regards,

 

Max

Visitor exgreyfox
Visitor
16,691 Views
Registered: ‎04-08-2009

Re: Invalid device driver license. Cable connection failed.

This exact same problem started to occur for me a few days ago completely out of the blue as well. I tried everything to no avail until I found this post, more particularly maxomicron's suggested solution worked. Thanks sir. 

0 Kudos
Newbie c44aej
Newbie
13,477 Views
Registered: ‎06-27-2016

Re: Invalid device driver license. Cable connection failed.

I had a similar problem with a fresh install of Xilinx Lab Tools v14.7.  My problem was a conflict with a PE Micro driver which uses a newer version of the windrvr6.sys driver.  This is the PE Micro solution which worked for me:

 

http://www.pemicro.com/faqs/faq_view.cfm?id=225

0 Kudos
Newbie kunalgaur
Newbie
13,453 Views
Registered: ‎06-08-2015

Re: Invalid device driver license. Cable connection failed.

Thanks @maxomicron , This solution worked for me.

 

Regards,

Kunal

0 Kudos
Newbie martincz
Newbie
13,125 Views
Registered: ‎07-20-2016

Re: Invalid device driver license. Cable connection failed.

Met this "cable not detected" problem on Dell Latitude E6440 Windows 7 64-bit.

 

For me, neither Lab Tools 14.7 nor Vivado Lab 2016.2 are able to detect the DLC10 cable when new windrvr6.sys driver is in place.

(even though the Device Manager shows no problems with attached USB devices, and yellow/green LED on DLC10 is on).

 

windrvr6.sys version 11.7 --> cable not detected

windrvr6.sys version 10.21 - OK

 

0 Kudos
Visitor layclg
Visitor
13,025 Views
Registered: ‎07-08-2016

Re: Invalid device driver license. Cable connection failed.

Hi,

 

I had the same problem:

I was working with Vivado 2016.2 on Win7 64bit and one day the connection via the cable was no more possible.

Vivado does not tell much about the problem. Just that there is no target available. Yippie!

But Impact did tell me the "Invalid device driver license" hint. Thats why I found this thread.

 

I tried to reinstall the driver several times without luck.

When I looked at the windrvr6.sys in C:\Windows\System32\drivers i saw the file size still beeing bigger than the one delivered with Vivado in C:\Xilinx\Vivado\2016.2\data\xicom\cable_drivers\nt64

 

So what finally worked for me was part of the solution of maxomicron:

I just deleted the current C:\Windows\System32\drivers\windrvr6.sys without uninstalling the driver first.

and

reinstalled the driver with admin rights (C:\Xilinx\Vivado\2016.2\data\xicom\cable_drivers\nt64\install_drivers.exe)

 

This changed the driver version in the device manager from 11.7 to 10.21 as martincz also told.

 

I did not try but I could imagine that it would be enough to just replace the Windows file with the Vivado file.

 

12,695 Views
Registered: ‎08-03-2016

Re: Invalid device driver license. Cable connection failed.

Thanks for maxomicron's solution, I got the same problem but solved it!
0 Kudos
Visitor kenny.leong
Visitor
12,419 Views
Registered: ‎06-07-2016

Re: Invalid device driver license. Cable connection failed.

I had the same issue....but eventually (after a LONG TIME) got IMPACT within ISE 14.5 to recognise a xilinx platform cable in 32-bit Windows 8.1.

 

The following information was particularly useful.....

 

layclg: "I just deleted the current C:\Windows\System32\drivers\windrvr6.sys without uninstalling the driver first."

 

This windrvr6.sys is from Jungo ..... which should appear in the windows DEVICE MANAGER pop-up table. I right-clicked on Jungo, and chose 'update driver' - and chose the 'automatic' search option. This led to an automatic online search for a Jungo driver update (which updated windrvr6.sys).

 

The platform cable was then detected by the IMPACT software.

0 Kudos
Observer hugo74
Observer
10,610 Views
Registered: ‎04-14-2013

Re: Invalid device driver license. Cable connection failed.

Well, now I have the same problem but can't solve it at all. I tried all the solutions described in this thread without success.

I reinstalled ISE twice, deleted drivers and installed them manually and atomatically but to no avail...

Still get the "Invalid device driver license" message. I have Windows 10 and ISE WebPack 14.7. There was no problem for 4 months but some day it stopped to work correctly. 

0 Kudos
Visitor 0926006
Visitor
10,329 Views
Registered: ‎11-23-2016

Re: Invalid device driver license. Cable connection failed.

hey, 

 

I want to endorse that macomocron's answer helped me, too. 

https://forums.xilinx.com/t5/Configuration/Invalid-device-driver-license-Cable-connection-failed/m-p/653481/highlight/true#M5253

Altough I didn't have the issue with ISE, but Vivado (several versions from 2014, 2015, 2016) I found this post after I tried to connect to Platform Cable USB using Impact.

I hope many people find this solution here!

 

Thank you! 

 

just a few tags:

Vivado

Xilinx Platform Cable II

no hardware target

open target

auto connect

0 Kudos
Highlighted
Scholar golson
Scholar
3,820 Views
Registered: ‎04-07-2008

Re: Invalid device driver license. Cable connection failed.

0 Kudos
Visitor jesortsan78
Visitor
3,188 Views
Registered: ‎03-10-2015

Re: Invalid device driver license. Cable connection failed.

Thanks @maxomicron , That solution also worked for me.

 

I got this error after installing Vivado. Before that, I was using ISE 14.7 only and I never got an issue like that.

 

Regards

0 Kudos
2,151 Views
Registered: ‎06-08-2018

Re: Invalid device driver license. Cable connection failed.

It works for me. Thank you!

0 Kudos
2,020 Views
Registered: ‎06-25-2018

Re: Invalid device driver license. Cable connection failed.

Hi,

 

May i know how to solve this issue at ISE9.2i? Please advise. Thanks.


@paulclaessen.com wrote:

To clarify:
In my case, this driver problem started after I installed Vivado on the same machine I used to use ISE on,
A coworker of mine had exactly the same problem. After he uninstalled, and then re-installed ISE, everything worked again for him.
For some reason this didn't work for me.
However, after I ran the install_drivers.exe program, everything worked again.

So, here is my suggestion:


- Find the install_drivers.exe program in the Xilinx directory tree: in my case it was in 
   C:\Xilinx\14.7\ISE_DS\ISE\bin\nt64   (\nt if you're on a 32 bit machine)

- Open a 'dos box' as administrator(!), and cd to the above directory

- run 'install_drivers.exe'

 

Let us know if this works for you as well!



@paulclaessen.com wrote:

To clarify:
In my case, this driver problem started after I installed Vivado on the same machine I used to use ISE on,
A coworker of mine had exactly the same problem. After he uninstalled, and then re-installed ISE, everything worked again for him.
For some reason this didn't work for me.
However, after I ran the install_drivers.exe program, everything worked again.

So, here is my suggestion:


- Find the install_drivers.exe program in the Xilinx directory tree: in my case it was in 
   C:\Xilinx\14.7\ISE_DS\ISE\bin\nt64   (\nt if you're on a 32 bit machine)

- Open a 'dos box' as administrator(!), and cd to the above directory

- run 'install_drivers.exe'

 

Let us know if this works for you as well!


 

0 Kudos