UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
183 Views
Registered: ‎02-19-2019

Partial Reconfiguration

Hi,

I am trying to run Partial Reconfiguration Tutorial targeting on KC705: Lab 5: Partial Reconfiguration Controller IP
for 7 Series Devices Flow" given in "ug947.

When i try to run full and partial images, source the following scripts in Tcl mode
using the commands below.

vivado -mode tcl -source design.tcl

It is continuously running without giving any error
I am using Vivado v2018.3 for Partial Reconfiguration.
I want to know why it is running continuously without generating IP
If anybody can explain the reason why it is not able to generate .

0 Kudos
1 Reply
Moderator
Moderator
141 Views
Registered: ‎06-05-2013

Re: Partial Reconfiguration

can you try to run them again. I just tried and it works fine. there is a note for KC705 though which says make this changes to source tcl. 

IMPORTANT: Before running this Tcl script, open it to set the value of the xboard variable. KC705 is the default, but VC707 or VC709 can be selected.

Look for the step which Vivado is running in background. May be do a reset_project and give a rerun.

Also try at some local directory if you are using remote directory. do a cd to UG947 files directory and give a source from there. 

Share the vivado log if it doesn't work.

Thanks

harshit

 
-------------------------------------------------------------------------
Don’t forget to reply, kudo, and accept as solution.
-------------------------------------------------------------------------