UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Adventurer
Adventurer
91 Views
Registered: ‎09-28-2017

Possible to run previous version of hw_server?

Jump to solution

Hi, I am running Windows 10 with two versions of Vivado 2018.3 and 2014.3. 
I installed Vivado 2018.3 first and everything was working fine including hw_server. I was able to use JTAG no problem. 
Then I installed Vivado 2014.3 and everything seems fine except when I open the hardware manager and try to open a new hardware target. I get the following: 

WARNING: [Labtoolstcl 44-26] No hardware targets exist on the server [localhost]
Check to make sure the cable targets connected to this machine are properly connected
and powered up, then use the disconnect_hw_server and connect_hw_server commands
to re-register the hardware targets.


I already tried opening the hw_server from the 2014.3 directory manually and then trying to connect to the target but it does not work. 
If I try the same with 2018.3 everything is working correctly.. So this made me wonder if there could be some incompatibility issues with running two different hw_server on the same PC even if they are not running at the same time. Or maybe 2014.3 hw_server is not compatible with Windows 10? 
I would appreciate any suggestion on how to solve this. 

0 Kudos
1 Solution

Accepted Solutions
Xilinx Employee
Xilinx Employee
50 Views
Registered: ‎08-10-2008

回复: Possible to run previous version of hw_server?

Jump to solution

https://www.xilinx.com/support/answers/54242.html

2014.3 does not support on Windows 10.

If both versions are supported on one OS, they should be able to work separately.

------------------------------------------------------------------------------------------------------------
Don't forget to reply, kudo, and accept as solution.
---------------------------------------------------------------------------------------------------------
0 Kudos
2 Replies
Xilinx Employee
Xilinx Employee
51 Views
Registered: ‎08-10-2008

回复: Possible to run previous version of hw_server?

Jump to solution

https://www.xilinx.com/support/answers/54242.html

2014.3 does not support on Windows 10.

If both versions are supported on one OS, they should be able to work separately.

------------------------------------------------------------------------------------------------------------
Don't forget to reply, kudo, and accept as solution.
---------------------------------------------------------------------------------------------------------
0 Kudos
Adventurer
Adventurer
42 Views
Registered: ‎09-28-2017

回复: Possible to run previous version of hw_server?

Jump to solution

@iguo 
Hi, thank you for this info. 
I have now installed Vivado 2014.3 on Ubuntu 14.04.5 since it is supported. 
I am now facing floating license issues but I will open a new topic for that. 

0 Kudos