UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

Problem using iMPACT on Window 10

Reply
Highlighted
Participant
Posts: 13
Registered: ‎10-27-2011

Problem using iMPACT on Window 10

I need to update the Firmware on a board that is accessible only in our customer site.

The Firmware was originally developed using ISE 14.2, and loaded on the board flash using iMPACT 14.2, the board flash was a 28f512p30 BPI.

The available portable PC for the updating uses Windows 10.

I have first downloaded the Xilinx Labtools version 14.2 on this PC, but it was impossible to install the tools (as soon as I launch the setup program it exits)

Then I have downloaded the Labtools version 14.7 and I succeeded in installing these on my PC.

However the led on the programming probe (a Platform cable USB DLC9G) remains off.

After a search on the net I concluded that the drivers were not correctly installed and a I find a procedure that should correct this situation:

 

1) From the Hardware Management tool uninstall the Xilinx cable device deleting the driver,

2) From the Hardware Management tool uninstall the Jungo device deleting the driver,

3) manually delete the file windrv6.sys from the folder Window/System32/drivers,

4) launch the executable install_drivers that I found in the Labtools folder

 

The result of this procedure is that the green led on the probe is on when connected to the board.

However iMPACT is still not capable to connect to the hardware: when I launch the "Initialize JTAG chain" procedure  the warning message "WARNING:iMPACT:923 Cannot find cable, check cable setup" is displayed.

 

On the same PC I have also Vivado 18.1. I have tried to launch the Hardware Manager from Vivado, but when I try to open the target ("Open Target" then "Auto Connect") it fails and the following message is displayed:

"[Labtools 27-2269] No devices detected on target."

 

Moreover it appears that Vivado 18.1 does not recognize the flash memory, it can use 28f512p30e, 28f512p30b, and 28f512p30t, but not 28f512p30.

 

Could someone suggest how I can make iMPACT or Vivado make the connection to the hardware and how Vivado can be used for programming the flash 28f512p30?

 

many thanks

Xilinx Employee
Posts: 369
Registered: ‎08-10-2008

回复: Problem using iMPACT on Window 10

Which FPGA device you are using?

Note that ISE is no longer supported on Win10; if you are using Spartan-6, Xilinx provides a ISE VM version for S6 on Win10.

For Vivado, you should make sure the FPGA part is supported in Vivado tool as well.

Ivy
------------------------------------------------------------------------------------------------------------
Don't forget to reply, kudo, and accept as solution.
---------------------------------------------------------------------------------------------------------
Participant
Posts: 13
Registered: ‎10-27-2011

回复: Problem using iMPACT on Window 10

The FPGA is a Kintex 7 xc7k160t

Xilinx Employee
Posts: 190
Registered: ‎03-07-2018

回复: Problem using iMPACT on Window 10

[ Edited ]

Hi @marcovalerioa

 

Did you tried changes as mentioned at AR#62380?

 

As you mentioned "Moreover it appears that Vivado 18.1 does not recognize the flash memory, it can use 28f512p30e, 28f512p30b, and 28f512p30t, but not 28f512p30. " All three flashes are supported by Xilinx [UG908 (v2018.2) Page 334].

 

K7 supported BPI Micron.jpg

 

 Let us know complete part no. of your flash.

 

Regards,

Bhushan

-------------------------------------------------------------------------------------------------------------------------------------------------
Kindly note- Please mark the Answer as "Accept as solution" if information provided is helpful.
Give Kudos to a post which you think is helpful and reply oriented.
-------------------------------------------------------------------------------------------------------------------------------------------------

Xilinx Employee
Posts: 369
Registered: ‎08-10-2008

回复: Problem using iMPACT on Window 10

1. Vivado only supports p30b/e/t x16 mode, check if the flash has the suffix;
2. ISE cannot be used on Win10 for K7.
3. You should first figure out why your fpga cannot be detected. It's due to a cable driver issue or installation issue. If you change to another board, with the same PC and Cable, can that board be detected?
------------------------------------------------------------------------------------------------------------
Don't forget to reply, kudo, and accept as solution.
---------------------------------------------------------------------------------------------------------
Observer
Posts: 64
Registered: ‎08-16-2018

Re: Problem using iMPACT on Window 10

iMPACT, ISE and Windows 10 seem to me like a potential source of trouble.

I would suggest a VM with 7 or XP even if clumsy.