UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
125 Views
Registered: ‎02-11-2019

Smart Lynq Cable HW_Server version flexibility?

Jump to solution

I would like to know if its possible to change the HW_Server version running the Smart Lynq Cable to an older version (2014.4)? or newer?

Details:

We have a wide range of products ranging from older Vivado (2014.2) based designs to newer (2018.1). The Smart Lynq cable is a great ethernet based JTAG solution and we would like to deploy it on all of our lab stations but we would need it to support not just our newer as well as our older cards. Another forum mentioned that:

"Basically, the rule is that the HW Manager (actually the hw_server process) does not talk to any Vivado/SDK that is newer than itself."

However when we try to connect an older 2014.4 HW_Manager to a newer 2017.3 HW_Server (running on Smart Lynq), we get a version mismatch error.

Also what is the latest supported HW_Server version for the Smart Lynq? Can we upgrade/downgrade firmware on demand?

 

Thanks,

Vincent

0 Kudos
1 Solution

Accepted Solutions
Moderator
Moderator
55 Views
Registered: ‎02-09-2017

Re: Smart Lynq Cable HW_Server version flexibility?

Jump to solution

Hi @vincent.ibanez,

In the case of the SmartLynq cable, its firmware must be exactly on the same version as the hw_server that it's getting connected to.

You can easily upgrade/downgrade the firmware by running connetcing the Smartlynq to the HW Manager that you want to connect to, and then running the command:

update_hw_firmware -reset

Obs.: After updating the fimware you may need to cycle power on the SmartLynq and disconnect the USB cable.

You will only be able to downgrade the SmartLynq cable up to 2017.2. Before that, the cable did not exist, so there's no firmware that makes it compatible with older versions (so you will not be able to connect it to a Vivado / HW Manager 2014.4).

Thanks,

Andre Guerrero

Product Applications Engineer

-------------------------------------------------------------------------
Don’t forget to reply, kudo, and accept as solution.
-------------------------------------------------------------------------
2 Replies
Moderator
Moderator
56 Views
Registered: ‎02-09-2017

Re: Smart Lynq Cable HW_Server version flexibility?

Jump to solution

Hi @vincent.ibanez,

In the case of the SmartLynq cable, its firmware must be exactly on the same version as the hw_server that it's getting connected to.

You can easily upgrade/downgrade the firmware by running connetcing the Smartlynq to the HW Manager that you want to connect to, and then running the command:

update_hw_firmware -reset

Obs.: After updating the fimware you may need to cycle power on the SmartLynq and disconnect the USB cable.

You will only be able to downgrade the SmartLynq cable up to 2017.2. Before that, the cable did not exist, so there's no firmware that makes it compatible with older versions (so you will not be able to connect it to a Vivado / HW Manager 2014.4).

Thanks,

Andre Guerrero

Product Applications Engineer

-------------------------------------------------------------------------
Don’t forget to reply, kudo, and accept as solution.
-------------------------------------------------------------------------
47 Views
Registered: ‎02-11-2019

Re: Smart Lynq Cable HW_Server version flexibility?

Jump to solution

Thanks Andre for that information. I was able to connect 2016.1 HW_Manager to 2017.3 HW_Server but I can understand if the official stance is to match the version of the HW_Manager to the HW_Server.