UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
274 Views
Registered: ‎04-27-2018

Unable to boot from QSPI

I want to run linux on zu19eg. In Jtag mode, it run okay. And i program the dual qspi flash successfully. However, there is nothing output when i power on the board.

I am sure the qspi flash is okay because it boot jffs2 rootfs from qspi flash successfully in jtag mode. And the same model flash is work well on zu9eg.

So what is the problem? Any suggestions are appreciated!

0 Kudos
2 Replies
Moderator
Moderator
262 Views
Registered: ‎09-15-2016

Re: Unable to boot from QSPI

Hi @yannantian198656

What is the mode pin settings when you boot from the QSPI? What is the error you receive when you fail boot from the QSPI flash?

>>I am sure the qspi flash is okay because it boot jffs2 rootfs from qspi flash successfully in jtag mode.

Could you please clear on this statement? In JTAG mode, there is no boot from the QSPI flash. 

Regards
Rohit
----------------------------------------------------------------------------------------------
Kindly note- Please mark the Answer as "Accept as solution" if information provided is helpful.

Give Kudos to a post which you think is helpful and reply oriented.
----------------------------------------------------------------------------------------------

0 Kudos
247 Views
Registered: ‎04-27-2018

Re: Unable to boot from QSPI

Thank you for reply. The mode pin is set to QSPI32. There is no message output when boot. But the PL CONFIG_DONE is low, and the FPS_ERROR_OUT is high.
0 Kudos