UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Observer amassa
Observer
381 Views
Registered: ‎12-06-2018

Windriver Install Problems

I have a zedboard and am running SDK 2018.3 on Windows 10. I have tried numerous different methods to try to get the Jungo WinDriver to install but have been unsuccessful including the manual installation as described in

https://www.xilinx.com/support/answers/54381.html

I am able to get a Jungo device to show up in my device manager, but cannot complete the install of the WinDriver. The Jungo device shows "Unknown device". I have tried updating the driver to the xicom\cable_drivers\nt64\dlc10_win7, but that does not work either.

Not sure what else I can try.

Thanks for any help.

0 Kudos
2 Replies
Xilinx Employee
Xilinx Employee
345 Views
Registered: ‎03-07-2018

Re: Windriver Install Problems

Hello @amassa

Did you tried installing driver as per AR# 59128?

If above method does not work then, Perform all steps provided below for installing driver in Vivado:

  1. Make sure Platform Cable USB is unplugged
  2. Open a Windows cmd.exe prompt as Administrator
  3. In a command prompt browse to " <Vivado Install Directory>\data\xicom\cable_drivers\nt64\dlc10_win7" 
  4. To uninstall type the command: wdreg -compat -inf %cd%\windrvr6.inf uninstall
  5. To uninstall type the command:  wdreg -compat -inf %cd%\xusbdrvr.inf uninstall
  6. Run command: net stop XilinxPC4Driver
  7. Delete with command: %WINDIR%\system32\drivers\windrvr6.sys
  8. Delete with command: %WINDIR%\system32\drivers\xusb*.sys
  9. Delete with command: %WINDIR%\system32\drivers\xpc4drvr.sys
  10. To reinstall type the command: wdreg -compat -inf %cd%\windrvr6.inf install
  11. Plug in USB cable
  12. Go to Windows Device Manager. Look for 'Jungo'. Make sure it says 'WinDriver' under Jungo

If not, right-click and select 'Update Driver Software'.  Select 'Search automatically for updated driver software'

  1. Go back to CMD prompt (With plugged in USB cable)
  2. To reinstall type the command: wdreg -compat -inf %cd%\xusbdrvr.inf install
  3. Programmer status light should turn on and be green, if attached to target
  4. Run 'Cable Auto Connect' to verify
Regards,
Bhushan

-------------------------------------------------------------------------------------------------------------------------------------------------
Kindly note- Please mark the Answer as "Accept as solution" if information provided is helpful.
Give Kudos to a post which you think is helpful and reply oriented.
-------------------------------------------------------------------------------------------------------------------------------------------------
Observer amassa
Observer
334 Views
Registered: ‎12-06-2018

Re: Windriver Install Problems

Thanks for the response @bpatil . I did try the AR#59128 sequence. The problem with that is that if windrvr6 is installed, it removes it.

I've come across the sequence you listed as well. It didn't work in that method for me when I tried it. I was finally able to get windriver to install under jungo and then had to restart my system, then install the usb driver.

0 Kudos