UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Newbie pemiliv
Newbie
14,267 Views
Registered: ‎04-03-2008

please, someone help, my system generator fails

i am using ms vista home premium, matlab r2007a, and xilinx ise 10.1, most everything works fine, but some blocks (xilinx blockset at simulink)
when click on them, in the simulink work space, it popups this :

Error evaluating 'Openfcn' callback of Xilinx Logical Block Block Block (mask)
'untitled/Logical'. Error using ==> <a
href="error:C\Xilinx\dsptools\9.2.01.1028\sysgen\bin\xlOpenGui.p.149.1'>xlOpenGui
at 149</a>
Error using ==> xlCOMServer at 13
Unable to star COM server 'sysgengui9_2_01.XBlockGUI'. This may be caused by
a bad System Generator installation. Try registering the System Generator COM server
by running the command:
C:\Xilinx\dsptools\9.2.01.1028\sysgen\bin\sysgengui9_2_01.exe -regserver
if this does not correct the problem, then contact technical support.


please what can i do,,.. ?

0 Kudos
10 Replies
14,255 Views
Registered: ‎03-31-2008

Re: please, someone help, my system generator fails

You seem to use matlab2007a with ise10.1 and systemgenerator9.1.01. As far as I know you must have the ise and systemgenerator of the same version. The ISE webpack is free and the systemgenerator not. I'm afraid that you need to go back to the previous ISEwebpack.


0 Kudos
Newbie pemiliv
Newbie
14,243 Views
Registered: ‎04-03-2008

Re: please, someone help, my system generator fails

I have now ISE webpack 9.2 and still its give me the popups/problem ... what can i do ? !!!!!!
0 Kudos
Xilinx Employee
Xilinx Employee
14,215 Views
Registered: ‎08-07-2007

Re: please, someone help, my system generator fails

Microsoft Windows Vista is not currently supported by System Generator 10.1.  It will not work.  You need to use Windows XP to use System Geerator for DSP at this time.
0 Kudos
Visitor sghaiera
Visitor
14,176 Views
Registered: ‎01-16-2008

Re: please, someone help, my system generator fails

I am facing the same problem. I have ISE10.1, sysgen 10.1 and accelDSP 10.1. Matlab(R2006b) and windows Xp Sp2. it is giving the same error
0 Kudos
Xilinx Employee
Xilinx Employee
14,159 Views
Registered: ‎08-02-2007

Re: please, someone help, my system generator fails

sghaiera,

If you have Vista and are getting the same error above then the problem is Vista. Check out AR 17966 (http://www.xilinx.com/support/answers/17966.htm) for compatibility requirements. I see you have Matlab 2006b installed. It is suggested that you have 2007a or 2007b for Sysgen 10.1.


RJ Duran
Customer Application Engineer
Technical Support: http://www.xilinx.com/support
Xilinx User Community: http://forums.xilinx.com
0 Kudos
Newbie cinziamoca
Newbie
8,923 Views
Registered: ‎10-29-2008

Re: please, someone help, my system generator fails

I am facing the same problem. I have ISE10.1, sysgen 10.1 and accelDSP 10.1. Matlab(R2007b) and windows Xp Sp2. it is giving the same error for all blocks!!!!!!.
0 Kudos
Newbie a1b2c36
Newbie
8,294 Views
Registered: ‎01-28-2009

Re: please, someone help, my system generator fails

You may try shutting down the UAC. It works in my Microsoft Vista Premium.

ise 10.1

system generator 10.1 sp3

matlab 2008a

0 Kudos
Adventurer
Adventurer
8,231 Views
Registered: ‎10-13-2007

Re: please, someone help, my system generator fails

Forgive my ignorance, but what is an UAC?

 

I see this problem now and then with sp10.1.03 of the Xilinx SW and Matlab 2008a.

 

 

0 Kudos
Adventurer
Adventurer
8,065 Views
Registered: ‎02-14-2009

Re: please, someone help, my system generator fails

I work with win vista home premium sp1, ise10.1sp3, matlab 2008a, sysgen 10.1sp3.

 

a1b2c36 rights. you need to disable UAC and reinstall Sysgen. 

 

To turn off UAC

Click Start, and then click Control Panel.

In Control Panel, click User Accounts.

In the User Accounts window, click User Accounts.

In the User Accounts tasks window, click Turn User Account Control on or off.

If UAC is currently configured in Admin Approval Mode, the User Account Control message appears. Click Continue.

Clear the Use User Account Control (UAC) to help protect your computer check box, and then click OK.

Click Restart Now to apply the change right away, or click Restart Later and close the User Accounts tasks window.
 

 

 

Visitor jar
Visitor
1,193 Views
Registered: ‎09-29-2011

Re: please, someone help, my system generator fails

Hi,

I use Windows XP and ISe 10.1.03 and system generator 10.1 with the service packs installed. I am also facing the same problem.How do I solve it?

The matlab version is Matlab R2008a.

0 Kudos