UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Participant jorlamp
Participant
306 Views
Registered: ‎01-12-2018

Deephi image get stuck in Starting Kernel for ZCU102

Hi!

I have a ZCU102 Revision 1.1 board and sometimes I am able to see Deephi Linaro Desktop and launch the example applications but other times I get stuck here:

Xilinx Zynq MP First Stage Boot Loader 
Release 2017.1   Sep 23 2018  -  18:42:16
NOTICE:  ATF running on XCZU9EG/silicon v4/RTL5.1 at 0xfffea000, with PMU firmware
NOTICE:  BL31: Secure code at 0x0
NOTICE:  BL31: Non secure code at 0x8000000
NOTICE:  BL31: v1.3(release):47af34b
NOTICE:  BL31: Built : 02:46:52, Jun 19 2018
PMUFW:  v0.3


U-Boot 2017.01 (Jun 27 2017 - 17:02:57 +0800) Xilinx ZynqMP ZCU102 revB

I2C:   ready
DRAM:  4 GiB
EL Level:       EL2
Chip ID:        xczu9eg
MMC:   sdhci@ff170000: 0 (SD)
reading uboot.env

** Unable to read "uboot.env" from mmc0:1 **
Using default environment

In:    serial@ff000000
Out:   serial@ff000000
Err:   serial@ff000000
Bootmode: LVL_SHFT_SD_MODE1
Net:   ZYNQ GEM: ff0e0000, phyaddr c, interface rgmii-id

Warning: ethernet@ff0e0000 using MAC address from ROM
eth0: ethernet@ff0e0000
Hit any key to stop autoboot:  0 
switch to partitions #0, OK
mmc0 is current device
Device: sdhci@ff170000
Manufacturer ID: 3
OEM: 5344
Name: SL08G 
Tran Speed: 50000000
Rd Block Len: 512
SD version 3.0
High Capacity: Yes
Capacity: 7.4 GiB
Bus Width: 4-bit
Erase Group Size: 512 Bytes
reading uEnv.txt
166 bytes read in 8 ms (19.5 KiB/s)
Loaded environment from uEnv.txt
Importing environment from SD ...
reading system.dtb
36852 bytes read in 16 ms (2.2 MiB/s)
reading Image
9689096 bytes read in 693 ms (13.3 MiB/s)
## Flattened Device Tree blob at 04000000
   Booting using the fdt blob at 0x4000000
   Loading Device Tree to 000000000fff4000, end 000000000ffffff3 ... OK

Starting kernel ...


What can I do to stop this randomness?

 

Thanks,

Jorge

0 Kudos
1 Reply
Explorer
Explorer
217 Views
Registered: ‎10-24-2008

Re: Deephi image get stuck in Starting Kernel for ZCU102

@jorlampThe first things that I would do are:

[1] Test with a different SD card.  I have used both Kingston and Sandisk cards with good results.  I am not aware of any issues, but the behaviour that you are seeing seems odd.

[2] Try the latest ZCU102 image file:  www.deephi.com/assets/2018-10-11-ZCU102-desktop-stretch.img.zip

[3] Confirm that all of the power rail LEDs are on.  It might be useful to snap a picture for both a good and bad boot to compare.  It is easy to not notice that one of the rails didn't come up properly.

[4] Reprogram the Maxim PMICs on the board.

https://www.xilinx.com/support/answers/66811.html

https://www.maximintegrated.com/en/storefront/search_result.html?type=sample&sampleSearchField=MAXPOWERTOOL002

Hope this helps!

--Quenton

0 Kudos