UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

Reply

2014.4 IP packager edif files are disabled.

Visitor
Posts: 15
Registered: ‎05-21-2015

2014.4 IP packager edif files are disabled.

Hi all

 

We just upgrade the vivado tool from 2014.2 to 2014.4.

 

I found out that when I right click on an IP and chose"Edit in IP Packager",  there are some warning message:

WARNING: [IP_Flow 19-3833] Not packaging sources file marked as disabled: '*.edf'.  (I changed the path to be *)

Each edf file will have one warning message.

 

And in "File Groups" the edf files are no longer in "Verilog Synthesis" group. (Previously in 2014.2 they were there.)

I tried manually add edf file into the group, another critical warning pop out:

[IP_Flow 19-3355] File group 'xilinx_verilogsynthesis' contains both HDL and structural netlist files. The flow may not compile any of the HDL file. The user should consider moving the structural netlist file to the top of the file group.

 

How do I add edf files to "the top of the file group"?

How to add edf files in IP packager?

 

Thanks

Zhenghui Wu

Moderator
Posts: 5,330
Registered: ‎09-20-2012

Re: 2014.4 IP packager edif files are disabled.

[ Edited ]

Hi,

 

Is the EDIF file shown under top module in hierarchy window?

 

If you open IP packager project and run Implementation does it complete successfully. Is the EDIF file picked properly during Implementation?

 

I have created a simple test case in Vivado 2014.4 and it is working fine. Attaching it here.

 

Thanks,

Deepika.

Thanks,
Deepika.
--------------------------------------------------------------------------------------------
Google your question before posting. If someone's post answers your question, mark the post as answer with "Accept as solution". If you see a particularly good and informative post, consider giving it Kudos (the star on the left)
Visitor
Posts: 15
Registered: ‎05-21-2015

Re: 2014.4 IP packager edif files are disabled.

Hi

 

I looked at your project.

The difference is that we even have an edf file for the top module.

So in the Hierarchy, we only have one .v file which is the top module, and we have the edf file for top module, and some other edf files for the down level modules.

 

I added the edf files to the project so that they are in the Design Source, but all the edf files are in the same level with top.v(maybe not the name "top").

 

And in the File Group of Package IP, I didn't see the edf files.

 

I run Implementation, it said "[Place 30-494] The design is empty" meaning it didn't pick the edf files.

But the same setting works fine with vivado 2014.2.

 

I then re-packaged IP in "Package IP" and close the project, and re-open the project by "Edit in IP packager" the edf files doesn't show under "Design Sources" in the "Hierarchy".

 

Thanks

Zhenghui Wu

Moderator
Posts: 5,330
Registered: ‎09-20-2012

Re: 2014.4 IP packager edif files are disabled.

Hi,

 

Does the EDIF file name match with the module name which you have specified in instantiation in top level file?

 

Can you attach a snapshot showing the hierarchy window?

 

Thanks,

Deepika.

Thanks,
Deepika.
--------------------------------------------------------------------------------------------
Google your question before posting. If someone's post answers your question, mark the post as answer with "Accept as solution". If you see a particularly good and informative post, consider giving it Kudos (the star on the left)
Visitor
Posts: 15
Registered: ‎05-21-2015

Re: 2014.4 IP packager edif files are disabled.

Hi,

 

This Ip works fine with vivado 2014.2, so the name for edf files should match with the .v file, as I didn't modify the source files.

 

Snapshot:

ip_packager.png

 

Thanks

Zhenghui

Visitor
Posts: 15
Registered: ‎05-21-2015

Re: 2014.4 IP packager edif files are disabled.

Hi

 

I also modified your sample project, I removed the top.v file and set up_counter.v as top. (Which is more like our setting)

 

sample_IP_packager.png

 

As you can see the edf file is not in the "File Groups" list, and implementation as design is empty.

 

Moderator
Posts: 5,330
Registered: ‎09-20-2012

Re: 2014.4 IP packager edif files are disabled.

Hi,

 

From your snapshot,

 

why do you have both netlist and HDL of module up_counter added to the design? Which one do you want the tool to use?

 

Thanks,

Deepika.

Thanks,
Deepika.
--------------------------------------------------------------------------------------------
Google your question before posting. If someone's post answers your question, mark the post as answer with "Accept as solution". If you see a particularly good and informative post, consider giving it Kudos (the star on the left)
Visitor
Posts: 15
Registered: ‎05-21-2015

Re: 2014.4 IP packager edif files are disabled.

Hi

 

The .v file only defines the input/output of the module, and .edf file contains the logic.

I think that's the way we do that, am I wrong?

 

Thanks

Zhenghui

 

Moderator
Posts: 5,330
Registered: ‎09-20-2012

Re: 2014.4 IP packager edif files are disabled.

[ Edited ]

Hi Zhenghui,

 

If you want to package the EDIF file as top module then remove this verilog file which is wrapper of EDIF file.

 

You can add this verilog wrapper file when adding the user IP in your top level design.

 

When you have both wrapper and EDIF file then the IP packager packages only one file which is set as top module.

 

Another method is to instantiate this EDIF file in a top module as I have done in my test design(attached in my earlier post).

 

Thanks,

Deepika.

Thanks,
Deepika.
--------------------------------------------------------------------------------------------
Google your question before posting. If someone's post answers your question, mark the post as answer with "Accept as solution". If you see a particularly good and informative post, consider giving it Kudos (the star on the left)
Visitor
Posts: 15
Registered: ‎05-21-2015

Re: 2014.4 IP packager edif files are disabled.

Hi

 

I tried to remove .v file from project and set .edf as top, and I can't run impl as "no netlist available" and can't run synth as "no HDL source in file set"

 

You said "When you have both wrapper and EDIF file then the IP packager packages only one file which is set as top module." Is it only for 2014.4? Because we did the samething in 2014.2 and never got this problem.

 

Thanks

Zhenghui