UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Explorer
Explorer
500 Views
Registered: ‎07-28-2008

2018.2 IP Packager can't disable source file

Jump to solution

I tried right-click > disable file and Property uncheck "Enabled". Either method marks the file is disabled. But after Re-Package IP, and reopen, the disabled file is enabled again.

 

So the file disable doesn't seem to be useful for me for now. Am I doing something wrong?

 

Please comment.

Tags (1)
0 Kudos
1 Solution

Accepted Solutions
Moderator
Moderator
535 Views
Registered: ‎01-16-2013

Re: 2018.2 IP Packager can't disable source file

Jump to solution

@legendbb,

 

The changes of disabling files which you are making are in temp project. You need to use remove file option in Files groups under packager to see the changes getting reflected in repackaged IP. 

 

--Syed

---------------------------------------------------------------------------------------------
Kindly note- Please mark the Answer as "Accept as solution" if information provided is helpful.
Give Kudos to a post which you think is helpful and reply oriented.

Did you check our new quick reference timing closure guide (UG1292)?
---------------------------------------------------------------------------------------------
0 Kudos
3 Replies
Moderator
Moderator
499 Views
Registered: ‎01-16-2013

Re: 2018.2 IP Packager can't disable source file

Jump to solution

@legendbb,

 

But after Re-Package IP, and reopen, the disabled file is enabled again

By reopen, do you mean opening the project which has custom IP? You need to reset and regenerate the IP output products and also check if there is any change in IP instantiation template. 

 

--Syed

---------------------------------------------------------------------------------------------
Kindly note- Please mark the Answer as "Accept as solution" if information provided is helpful.
Give Kudos to a post which you think is helpful and reply oriented.

Did you check our new quick reference timing closure guide (UG1292)?
---------------------------------------------------------------------------------------------
0 Kudos
Explorer
Explorer
485 Views
Registered: ‎07-28-2008

Re: 2018.2 IP Packager can't disable source file

Jump to solution

Hi, Syed,

 

Thanks for reply. I reopen the IP project in IP packager. I tried remove file from the IP project and make sure file inclusion in IP GUI File Groups is updated, then repack. Then I can move on to generate the instantiation design.

 

I started the IP project by: Tools > Create and Package New IP > Package a specified directory

 

Maybe I shall try other IP workflow.

0 Kudos
Moderator
Moderator
536 Views
Registered: ‎01-16-2013

Re: 2018.2 IP Packager can't disable source file

Jump to solution

@legendbb,

 

The changes of disabling files which you are making are in temp project. You need to use remove file option in Files groups under packager to see the changes getting reflected in repackaged IP. 

 

--Syed

---------------------------------------------------------------------------------------------
Kindly note- Please mark the Answer as "Accept as solution" if information provided is helpful.
Give Kudos to a post which you think is helpful and reply oriented.

Did you check our new quick reference timing closure guide (UG1292)?
---------------------------------------------------------------------------------------------
0 Kudos