cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
doogul
Visitor
Visitor
3,405 Views
Registered: ‎01-06-2019

2018.3 block design zoom broken on Linux

I installed Vivado 2018.3 and noticed that the "Zoom Fit" function seems broken in the block design editor. I'm using Ubuntu Linux 18.04. When I click it (or if I just simply open the block design) it defaults to zoomed *way* out. I have to zoom in a bunch to find my design. It also zooms way out if I click "Regenerate Layout".

It's happening on both a brand-new design as well as an existing design I upgraded from 2017.3 to 2018.3. I've attached an example screenshot of how it looks when I initially open the block design (or after I click "Zoom Fit").

ExampleScreenshot.png
0 Kudos
18 Replies
rshekhaw
Xilinx Employee
Xilinx Employee
3,362 Views
Registered: ‎05-22-2018

Hi @doogul,

I checked for one test design which is migrated from Vivado 2017.4 to Vivado 2018.3 and the block design got open with proer zoomed in.

Can you please share your test design to reproduce the issue at my end.

Thanks,

Raj

0 Kudos
doogul
Visitor
Visitor
3,328 Views
Registered: ‎01-06-2019

Hi @rshekhaw,

Thanks for checking it out. Any design does it. Here is a set of steps for creating a simple design demonstrating the issue:

  • Open Vivado 2018.3
  • Under Quick Start, click Create Project
  • Click Next
  • Name the project whatever you want, and click Next
  • Click Next (RTL Project)
  • Click Next (don't add any sources)
  • Click Next (don't add any constraints)
  • For the default part, I picked xc7z020clg400-3, then click Next
  • Click Finish
  • Under IP INTEGRATOR, click Create Block Design
    • Click OK
  • Press the + button to add IP
  • Add a ZYNQ7 Processing System
  • You can already tell something is wrong at this point, because the ZYNQ7 processing system appears as a tiny square just a few pixels in size.
  • If you click Zoom Fit at this point, it also stays zoomed way out.

Again, in case it matters, I'm running Ubuntu 18.04. Specifically I'm running Ubuntu MATE 18.04. This problem does not happen in Vivado 2017.3. I've attached a screen recording of the problem in action (it's a webm video playable using Chrome or VLC Media Player).

Thanks!

0 Kudos
doogul
Visitor
Visitor
3,347 Views
Registered: ‎01-06-2019

Hi @rshekhaw,

I already responded to your message once, and it appears that maybe my response was blocked or something? The post went through, and now it seems to have disappeared. Anyway, in that response I posted a video showing the problem. Hopefully the forum moderator can fix my blocked response so you can see the video. The gist of my message was that it doesn't matter; just create a new project, create a block design, and add an IP block. It will appear zoomed way out by default, and the "zoom fit" button also won't zoom in. I'm using Ubuntu MATE 18.04, and this problem doesn't happen with 2017.3.

0 Kudos
rshekhaw
Xilinx Employee
Xilinx Employee
3,325 Views
Registered: ‎05-22-2018

Hi @doogul,

Thanks for the information, will get back soon after checking.

Regards,

Raj Singh.

0 Kudos
rshekhaw
Xilinx Employee
Xilinx Employee
3,304 Views
Registered: ‎05-22-2018

Hi @doogul,

I tried to reproduce the issue following the steps shared from your end, but it didn't reproduced at my end.

When i added the IP it appeared in normal size, please thake reference from snapshot:

zynqCapture.JPGRegards,

Raj.

0 Kudos
doogul
Visitor
Visitor
3,293 Views
Registered: ‎01-06-2019

Hi @rshekhaw,

Hmm, weird. I wonder why it's only happening to me. What's weird about it is that 2017.3 doesn't have the problem...only 2018.3. I guess I can try some different distros in a VM to try to narrow the problem down further. That will take me a while to do. It looks like you're running Red Hat. Maybe the problem is limited to Ubuntu or something.

0 Kudos
doogul
Visitor
Visitor
3,272 Views
Registered: ‎01-06-2019

I made a bunch of virtual machines, and I am unable to reproduce the problem I reported in any of my VMs. That includes Ubuntu 16.04, Ubuntu 18.04, Ubuntu MATE 16.04, and Ubuntu MATE 18.04. So this must be something specific to my computer. I'm not sure what's going on with my particular computer, but it doesn't seem to be a general problem because everything works fine in a virtual machine running the exact same version of Ubuntu.

0 Kudos
doogul
Visitor
Visitor
3,168 Views
Registered: ‎01-06-2019

I wanted to add one last piece of information. This problem also does not occur in 2018.2. So something about the combination of 2018.3 and my computer seems to be broken for zooming. I've reinstalled 2018.3 multiple times just in case it was a corrupted install or something. Something has changed in 2018.3 that breaks the zoom functionality on my computer.

Edit: I suspect this is probably related to how 2018.3 claims to now have native high-resolution monitor support.

0 Kudos
wickmann
Observer
Observer
3,076 Views
Registered: ‎09-01-2017

I have the same problem with Ubuntu 16.04 and Vivado 18.3

0 Kudos
anunesgu
Moderator
Moderator
3,052 Views
Registered: ‎02-09-2017

Just updating on this issue, Xilinx is aware of it and there is already an internal Change Request (CR-1016551) for investigating and fixing this issue.

At the moment, unfortunately there is no patch or workaround yet, other than manually zooming in.

We'll update as we have more info on this case.

Thank you!

Andre Guerrero

Product Applications Engineer

-------------------------------------------------------------------------
Don’t forget to reply, kudo, and accept as solution.
-------------------------------------------------------------------------
0 Kudos
doogul
Visitor
Visitor
3,044 Views
Registered: ‎01-06-2019

Thanks for the update, Andre. I appreciate it! And thank you wickmann for confirming that you saw the issue too...at least now I know I'm not going crazy! :-)

0 Kudos
latilgan
Newbie
Newbie
2,862 Views
Registered: ‎02-02-2019

First of all, I would like to mention that I have encountered the same problem. And I'm moving the situation even further, and I'm telling you that there are problems with Chipscope (CS) wave windows. Zoom and CS problems started after Vivado 2017.3 (with Vivado 2018.1). I first thought these were problems with Vivado, but I realized that the problems were caused by the VMware agent. Because I have never encountered any of the problems mentioned in physical machines. When the connection is opened using the VMware viewagent on Ubuntu Mate 16.04 and Ubuntu Mate 18.04 virtual machines (using Horizon Client), zoom and CS problems start. For my part, I couldn't find a permanent solution to the problem, but I found a way to overcome it. After the boot of the VM, you connect it with the Horizon Client. You then log out (not re-boot or shutdown) and re-connect to the VM with Horizon Client. So the VMware agent is re-started. You will no longer see the above mentioned errors unless you change the number or resolution of the monitors. You must repeat this logout-reconnect cycle after each re-boot or shutdown.

0 Kudos
mruiz1
Observer
Observer
2,714 Views
Registered: ‎04-22-2016

Hello,

I'm facing the same issue. It's so frustrating because the "zoom out" happens even when I make a connection between two ports.

I'm running CentOS 7, if this helps to solve the issue.

Mario

0 Kudos
hamidnaghi
Visitor
Visitor
2,689 Views
Registered: ‎03-12-2018

Today, I installed vivado version 2018.3 and it's hapened to me too. I coould fix it by a ubuntu display setting. I change the "scale for menu and title bars" to 1

mruiz1
Observer
Observer
2,666 Views
Registered: ‎04-22-2016

Hi @hamidnaghi,

The work around that you mentioned works for CentOS 7 and gnome 3. Thank you for the solution, now it is possible to work with Vivado 2018.3.

You have to execute Gnome Tweak and then in the left hand side menu select Fonts, and set Window Title to 1 and Scaling Factor to 1 as well. Check the image or this post https://unix.stackexchange.com/questions/257163/reduce-title-bar-height-in-gnome-3-gtk-3

Mario

 

Screenshot from 2019-02-16 12-04-08.png
0 Kudos
krishnan
Xilinx Employee
Xilinx Employee
2,566 Views
Registered: ‎09-25-2007

This is fixed in 2019.1.

For 2018.3, Please use /usr/bin/gnome-tweak-tool to change the "Scaling factor" as shown above to 1.0.

0 Kudos
dje666
Explorer
Explorer
1,927 Views
Registered: ‎04-21-2017

Hi Hamidnaghi,

So happy you found a solution for Ubuntu machines. This has fixed all 5 of my 15 training laptops that where exhibiting the issue! However the issue only appeared on the Older Elite books, not the newer machines? All running 16.04lts and the same 2018.3 installation...

DJE666

0 Kudos
yeyang_alibaba
Visitor
Visitor
989 Views
Registered: ‎07-01-2019

Just FYI, the gnome-tweak-tool doesn't work for me on OpenSuSE. Instead, I had to set the DPI explicitly to a "custom" value of 96 to fix this issue.

0 Kudos