cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
simozz
Scholar
Scholar
827 Views
Registered: ‎05-14-2017

Adding -nolog -nojournal to defaults options

Jump to solution

Hello,

How can I run vivado with default options

-nolog -nojournal

without typing them every time I run the IDE from shell (Linux environment), and without makig a script that runs vivado from the Xilinx installation dirs ?

Can it be done using a default tcl file ?

Regards,

s.

0 Kudos
Reply
1 Solution

Accepted Solutions
philipwu
Xilinx Employee
Xilinx Employee
524 Views
Registered: ‎02-13-2020

Hi @simozz 


If that didn't work, then the best way to run the commands would be to create an alias in Linux. The alias can capture the -nolog and -nojournal commands. You can refer to the link below

https://alvinalexander.com/blog/post/linux-unix/create-aliases/

View solution in original post

8 Replies
philipwu
Xilinx Employee
Xilinx Employee
715 Views
Registered: ‎02-13-2020

Hi @simozz 

The best method to run Vivado with those default options is to create a TCL script and insert it in the installation directory as defined in AR# 53090 

Is there a particular reason why you do not want to run a script from the installation directory?

0 Kudos
Reply
simozz
Scholar
Scholar
675 Views
Registered: ‎05-14-2017

Hello @philipwu ,


Is there a particular reason why you do not want to run a script from the installation directory?


No, in fact I thought to use a tcl script file as I wrote in my post.

But I don't know hot to write this tcl file, so what exact instructions I have to use ?

Thanks.

s.

0 Kudos
Reply
philipwu
Xilinx Employee
Xilinx Employee
658 Views
Registered: ‎02-13-2020

Hi @simozz 

You can create a text file, and save as "vivado_init.tcl

Write the commands in the file, and save. Then you can place the file in the path described in AR 53090 



 

0 Kudos
Reply
simozz
Scholar
Scholar
634 Views
Registered: ‎05-14-2017

@philipwu ,

the steps you mention are elementary. I was referring to what TCL instructions must be used for my purpose.

I took a look into the Vivdo TCL docs but I did not find useful info.

s.

0 Kudos
Reply
philipwu
Xilinx Employee
Xilinx Employee
610 Views
Registered: ‎02-13-2020

Hi @simozz 

You can add the command set_param general.maxBackupLogs 0 into the tcl file

Reference post: https://forums.xilinx.com/t5/Vivado-TCL-Community/How-to-disable-backup-log-and-jou-files/td-p/288491

0 Kudos
Reply
simozz
Scholar
Scholar
571 Views
Registered: ‎05-14-2017

Content of /opt/Xilinx/Vivado/2019.2/scripts/Vivado_init.tcl is:

set_param general.maxBackupLogs 0

it seems it's ignored.

s.

 

0 Kudos
Reply
evgenis1
Advisor
Advisor
565 Views
Registered: ‎12-03-2007

Hi @philipwu ,

 

>> Is there a particular reason why you do not want to run a script from the installation directory?

Because it's a major headache to do. In my environment, Vivado installation is on a Linux server in some remote datacenter, and requires root access that I don't have. I'd need to spend time contacting the right people, explaining what to do, and hoping it's not going to affect other users.

Thanks,

Evgeni

0 Kudos
Reply
philipwu
Xilinx Employee
Xilinx Employee
525 Views
Registered: ‎02-13-2020

Hi @simozz 


If that didn't work, then the best way to run the commands would be to create an alias in Linux. The alias can capture the -nolog and -nojournal commands. You can refer to the link below

https://alvinalexander.com/blog/post/linux-unix/create-aliases/

View solution in original post