UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Explorer
Explorer
3,384 Views
Registered: ‎09-16-2010

Archiving of project from tcl script hangs and eats up memory

I am having an issue when archiving from a tcl script. The following line is printed out and the archive process never completes. 

 

"INFO:ProjectMgmt - Project Archive - Copying project files."

 

What is disturbing is that it seems to be in a loop while hanging in which it continually uses up more and more memory. I have seen this bug consume over 20 G before I killed the process. The memory is consumed by copying files over and over again into a /tmp folder it creates. 

 

I am using ISE 14.1 on rehat linux 5.7.

 

Has anyone seen this before? Is there anyway to see what is actually going on inside this loop?

 

Thanks.

Andrew
0 Kudos
2 Replies
Xilinx Employee
Xilinx Employee
3,355 Views
Registered: ‎07-22-2008

Re: Archiving of project from tcl script hangs and eats up memory

I'm not sure exactly what is going on.  We have had a few similar reports where the archive is adding recursive directory structure to the tmp archive location which results in a path too long error and an apparent hang.

This happened with projects containing sub-project source types (EDK specifically).

 

Does the same problem happen when archving from the GUI?

You can see some of what is going on bysetting the XIL_PROJNAV_FLOW_DEBUG_LEVEL environment variable.  The following command can be used in the Tcl console to set it.

   set env(XIL_PROJNAV_FLOW_DEBUG_LEVEL) 34

What command do you use for the archive?

If you have not done so already, can you try a short absolute path (e.g. "project archive /temp/myarchive.zip")?

 

0 Kudos
Explorer
Explorer
2,941 Views
Registered: ‎09-16-2010

Re: Archiving of project from tcl script hangs and eats up memory

This issue seems to have mysteriously disappeared. I'll try your suggestion if it happens again. 

 

It may have been related to this issue. 

 

http://forums.xilinx.com/t5/Design-Entry/Process-properties-missing-when-generating-tcl-script/m-p/278908#M3517

Andrew
0 Kudos