cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Highlighted
Visitor
Visitor
404 Views
Registered: ‎06-22-2012

Can you set Vivado to run off amazon corretto?

Jump to solution

The Computer admins at my Organization of removed Java from our computer systems.  Without Java Synthesis and other vivado functions will not operate.  How can I tell Vivado (2019.1) to use Corretto?  I know Vivado was not written to use Corretto but its all I have at the moment. 

0 Kudos
1 Solution

Accepted Solutions
Highlighted
Moderator
Moderator
242 Views
Registered: ‎06-14-2010

Hello @electricflow ,

I won't have an answer about Vivado and amazon corretto, however, from Vivado 2018.3 onward, Vivado uses and comes with Java version 9. This comes with the installation and Vivado will look for the Java version from within its own installer (e.g. /Xilinx/Vivado/2019.x/tps/lin/jre/). 
So, if your specific Java version on your machine was removed, when using Vivado 2019.2, it will use Java version from within its own install area, as indicated above.
FYI - Java SE 9 is currently a supported version of Java for Vivado 2019.2

Hope this helps.

Kind Regards,
Anatoli Curran,
Xilinx Technical Support
-------------------------------------------------------------------------
Don’t forget to reply, kudo, and accept as solution.
-------------------------------------------------------------------------

View solution in original post

2 Replies
Highlighted
Moderator
Moderator
243 Views
Registered: ‎06-14-2010

Hello @electricflow ,

I won't have an answer about Vivado and amazon corretto, however, from Vivado 2018.3 onward, Vivado uses and comes with Java version 9. This comes with the installation and Vivado will look for the Java version from within its own installer (e.g. /Xilinx/Vivado/2019.x/tps/lin/jre/). 
So, if your specific Java version on your machine was removed, when using Vivado 2019.2, it will use Java version from within its own install area, as indicated above.
FYI - Java SE 9 is currently a supported version of Java for Vivado 2019.2

Hope this helps.

Kind Regards,
Anatoli Curran,
Xilinx Technical Support
-------------------------------------------------------------------------
Don’t forget to reply, kudo, and accept as solution.
-------------------------------------------------------------------------

View solution in original post

Highlighted
Visitor
Visitor
209 Views
Registered: ‎06-22-2012

Thanks,  IT did verify it was using this Java. 

The problem ended up being they had restricted access to Jscript.DLL.   The restriction was not allowing me to synth any design.

 

Thanks