UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Participant zguo
Participant
2,262 Views
Registered: ‎05-19-2017

Custom ports missing from block design diagram

Jump to solution

I have a custom design that includes a series of AXI interfaces but also a couple of custom ports. In the symbol view inside of the Package IP tab I see all of those custom ports present. After I've packaged the IP and import it into my block design however, I don't see any of the ports to connect to anything else and I don't see anything obvious indicating if they're just hidden or they weren't packaged outright. So, how do I get custom ports to show up? I'm in Vivado 2017.1.

0 Kudos
1 Solution

Accepted Solutions
Highlighted
Participant zguo
Participant
4,233 Views
Registered: ‎05-19-2017

Re: Custom ports missing from block design diagram

Jump to solution

Found the problem, apparently you need to specify "wire" as part of the input/output definitions. Which, seems a bit nonobvious?

0 Kudos
1 Reply
Highlighted
Participant zguo
Participant
4,234 Views
Registered: ‎05-19-2017

Re: Custom ports missing from block design diagram

Jump to solution

Found the problem, apparently you need to specify "wire" as part of the input/output definitions. Which, seems a bit nonobvious?

0 Kudos