UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Explorer
Explorer
8,006 Views
Registered: ‎12-08-2007

I am using ISE on AMD 64 bit

I am using ISE 14.6

 

 

on AMD 64 bit linux

 

 

I get the message:

 

Architecture behavioral of Entity a is up to date.
/opt/Xilinx/14.6/ISE_DS/ISE/bin/lin64/unwrapped/xst: symbol lookup error: /opt/Xilinx/14.6/ISE_DS/ISE//lib/lin64/libCs_DeviceHelpers.so: undefined symbol: _ZN11Cs_Internal20DbgTracerInitCounterD1Ev

 

 

 

Please advise

 

thanks

Dag

0 Kudos
7 Replies
Moderator
Moderator
8,001 Views
Registered: ‎01-16-2013

Re: I am using ISE on AMD 64 bit

Hi,

Th *.so file mentioned in error looks corrupt.
If you have any successful installation of ISE on another machine copy *.so file to this system.

Also you can try to re-install the software.

Thanks,
Yash
0 Kudos
Xilinx Employee
Xilinx Employee
7,978 Views
Registered: ‎05-20-2015

Re: I am using ISE on AMD 64 bit

Hi @dag1,

This error can come up if the XST libraries fail to get loaded.

As a workaround you can use the LD_PRELOAD variable which can be used to load the required libraries (.so files)

 

setenv LD_PRELOAD /proj/xbuilds/ids_14.6_O.61xd.0.0/lin64/14.6/ISE_DS/ISE//lib/lin64/libXst_Core.so

 

Thanks,

Rajesh

 

0 Kudos
Explorer
Explorer
7,963 Views
Registered: ‎12-08-2007

Re: I am using ISE on AMD 64 bit

Hello and thanks for your answer

 

I reinstalled the .tar of ISE 14.6

 

But I get the same error

 

Dag

0 Kudos
Xilinx Employee
Xilinx Employee
7,960 Views
Registered: ‎05-20-2015

Re: I am using ISE on AMD 64 bit

Hi @dag1,
Did you try setting the LD_PRELOAD variable?

Thanks,
Rajesh
0 Kudos
Explorer
Explorer
7,948 Views
Registered: ‎12-08-2007

Re: I am using ISE on AMD 64 bit

I added the line:

export LD_PRELOAD=/more-space/Xilinx/14.6/ISE_DS/ISE/lib/lin64/libXst_Core.so

 

It solved the problem.

 

However, when I open a terminal window now I get a new error message:

 

/bin/sh: error while loading shared libraries: libPortability.so: cannot open shared object file: No such file or directory

 

 

 

It seems that setting the LD_PRELOAD to the .so caused this error

 

 

Any advice ?

 

Dag

 

0 Kudos
Moderator
Moderator
7,943 Views
Registered: ‎01-16-2013

Re: I am using ISE on AMD 64 bit

Hi,

 

Refer this AR http://www.xilinx.com/support/answers/22497.html for new issue.

 

Thanks,

Yash

0 Kudos
Explorer
Explorer
7,920 Views
Registered: ‎12-08-2007

Re: I am using ISE on AMD 64 bit

I followed the instruction 

putting in the PATH variable

 

(instead of nt folder using the following folder)

 

/Xilinx/14.6/ISE_DS/common/lib/lin64

 

which contains the file  libPortability.so

 

However, I still get the error

when I open a new terminal

 

error while loading shared libraries: libPortability.so: cannot open shared object file: No such file or directory

 

 

 

0 Kudos