cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Highlighted
Visitor
Visitor
4,872 Views
Registered: ‎05-11-2018

ISE WebPACK 14.7 on Ubuntu 18.04

Hello,

I upgraded the system from Ubuntu 16.04 to 18.04 - clear installation.

Today I installed ISE WebPACK 14.7.
The application starts, but I can't use Core Generator with Clock Wizard.

The error is:

   ERROR:sim - Unable to evaluate Tcl file:
      /opt/Xilinx/14.7/ISE_DS/ISE/coregen/ip/xilinx/primary/com/xilinx/ip/clk_wiz_v3_6/generate/run_legacy_tcl_flow.tcl
   ERROR:sim - Failed executing Tcl generator.
   ERROR:sim - Failed to generate 'clk_wiz_0'. Failed executing Tcl generator.

Whats the problem?

 

 

0 Kudos
4 Replies
Highlighted
Moderator
Moderator
4,679 Views
Registered: ‎06-14-2010

Hello @svy123,

 

Have you tried restarting your computer and then to see if it works or not?

 

However, please note that Ubuntu is not an supported OS for ISE.

 

Therefore you'd need to try on one of the supported OS as mentioned in the below doc.

 

http://www.xilinx.com/support/documentation/sw_manuals/xilinx14_7/irn.pdf

 

 

Kind Regards,
Anatoli Curran,
Xilinx Technical Support
-------------------------------------------------------------------------
Don’t forget to reply, kudo, and accept as solution.
-------------------------------------------------------------------------
0 Kudos
Highlighted
Moderator
Moderator
4,670 Views
Registered: ‎02-07-2008

Hi @svy123, just to add to what @anatoli mentioned, if restarting your machine does not overcome the issue, try running CoreGen in debug mode (i.e. coregen -ddd) to see if that provides any further information.

-------------------------------------------------------------------------
Don’t forget to reply, kudo, and accept as solution.
-------------------------------------------------------------------------
0 Kudos
Highlighted
Visitor
Visitor
3,266 Views
Registered: ‎07-12-2011

I just faced the same problem. Luckily, the solution is simple.

The problem is the JRE devievered with ISE is not compatible with the new Ubuntu libraries. This is good news, because you can replace it with the version installed in the Ubuntu.

Make a backup of the old JRE found in /opt/Xilinx/14.7/ISE_DS/ISE/java/lin64/ and replace it with a symlink to the system's JRE.
Highlighted
Observer
Observer
2,374 Views
Registered: ‎06-12-2009

Thanks @dlevit. I just wanted to confirm that your fix worked for me and add that I had to use the jre in the java 8 openjdk. I found that java-11 crashed when I tried to use coregen to compile the XPS_HWICAP. 

sudo apt install openjdk-8-jdk

cd /opt/Xilinx/14.7/ISE_DS/ISE/java/lin64/

sudo mv jre jre_backup

ln -s /usr/lib/jvm/java-8-openjdk-amd64/jre jre

0 Kudos