UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Contributor
Contributor
6,469 Views
Registered: ‎03-19-2015

MMCME2 in a wrong clock region

Jump to solution

Hello,

I'm using Vivado 2016.1 and I have a strange problem. I used ClockingWizard to adjust the frequency of an external clock (gps_clk) and it was working nicely, on default settings, I only changed output frequency. Then I added another ClockinWizard to adjust different clock (stable_20MHz). Then I get en error: [Place 30-575] Sub-optimal placement for a clock-capable IO pin and MMCM pair. After I added set_property CLOCK_DEDICATED_ROUTE FALSE I was able to generate the design, and indeed input pin and MMCM were in different clock regions. Input in X1Y1, MMCM in X1Y0, so it is wrong. However, there is an MMCM in X1Y1 region that is not used.

So the question is: Why Vivado doesn't use it instead?

I'm doing everything on default settings, is there a way to force Vivado to use the correct one?

Screenshot from 2016-06-30 11-49-45.png

Screenshot from 2016-06-30 11-50-48.png

 

0 Kudos
1 Solution

Accepted Solutions
Contributor
Contributor
11,324 Views
Registered: ‎03-19-2015

Re: MMCME2 in a wrong clock region

Jump to solution

OK, I looked into it again and it was my fault. I used wrong pin as an input (not clock-capable). Error message wasn't very clear, and after setting CLOCK_DEDICATED_ROUTE FALSE it actually placed it in wrong clock region, which is still strange but fixing the first problem made this one disappear. So it was not a tool issue, it was my eyes issue. Thank you for your answer I'm marking this as solved.

0 Kudos
2 Replies
Xilinx Employee
Xilinx Employee
6,400 Views
Registered: ‎09-20-2012

Re: MMCME2 in a wrong clock region

Jump to solution

Hi @mkarwat

 

Are you saying that there is an unused MMCM location in clock region X1Y1 and tool is failing to use it?

 

You can try locking the MMCM instance using constraint below (remove clock_dedicated_route constraint)

 

set_property LOC MMCM_site_name [get_cells MMCM_cell_name]

 

If this works then this is tool issue, please upload _opt.dcp file here.

Thanks,
Deepika.
--------------------------------------------------------------------------------------------
Google your question before posting. If someone's post answers your question, mark the post as answer with "Accept as solution". If you see a particularly good and informative post, consider giving it Kudos (the star on the left)
0 Kudos
Contributor
Contributor
11,325 Views
Registered: ‎03-19-2015

Re: MMCME2 in a wrong clock region

Jump to solution

OK, I looked into it again and it was my fault. I used wrong pin as an input (not clock-capable). Error message wasn't very clear, and after setting CLOCK_DEDICATED_ROUTE FALSE it actually placed it in wrong clock region, which is still strange but fixing the first problem made this one disappear. So it was not a tool issue, it was my eyes issue. Thank you for your answer I'm marking this as solved.

0 Kudos